summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a1fe56f71c8..f09a0b18ff73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Apr 17 19:16:15 UTC 2016
+# Tue Jan 2 12:55:40 UTC 2018
pkgbase = todoman-git
pkgdesc = A simple CalDav-based todo manager.
pkgver = latest
@@ -9,14 +9,20 @@ pkgbase = todoman-git
license = MIT
checkdepends = python-pytest
checkdepends = python-hypothesis
+ checkdepends = python-pytest-runner
+ checkdepends = python-freezegun
+ checkdepends = python-pytest-cov
depends = python-icalendar
depends = python-urwid
depends = python-xdg
- depends = python-ansi
depends = python-parsedatetime
depends = python-atomicwrites
depends = python-click
depends = python-setuptools-scm
+ depends = python-configobj
+ depends = python-dateutil
+ depends = python-tabulate
+ depends = python-humanize
optdepends = python-click-repl-git: the repl command.
provides = todoman
conflicts = todoman
diff --git a/PKGBUILD b/PKGBUILD
index 0349cef12905..a8fd9dfc9696 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,12 @@ pkgdesc="A simple CalDav-based todo manager."
arch=("any")
url="https://github.com/pimutils/todoman"
license=('MIT')
-depends=(python-icalendar python-urwid python-xdg python-ansi
- python-parsedatetime python-atomicwrites python-click
- python-setuptools-scm)
+depends=(python-icalendar python-urwid python-xdg python-parsedatetime
+ python-atomicwrites python-click python-setuptools-scm
+ python-configobj python-dateutil python-tabulate python-humanize)
optdepends=('python-click-repl-git: the repl command.')
-checkdepends=('python-pytest' 'python-hypothesis')
+checkdepends=('python-pytest' 'python-hypothesis' 'python-pytest-runner'
+ 'python-freezegun' 'python-pytest-cov')
conflicts=("todoman")
provides=("todoman")
source=(git+https://github.com/pimutils/todoman.git)