summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--todotxt.install17
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01080a7b5a5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = todotxt
+ pkgdesc = lifehacker.com's todo.sh script for maintaining a todo.txt file
+ pkgver = 2.10
+ pkgrel = 2
+ url = http://ginatrapani.github.com/todo.txt-cli/
+ install = todotxt.install
+ arch = any
+ license = GPL
+ depends = bash
+ source = https://github.com/ginatrapani/todo.txt-cli/releases/download/v2.10/todo.txt_cli-2.10.tar.gz
+ md5sums = d90098b5f031d117faf129a4c90e812d
+
+pkgname = todotxt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dd210862a0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# lifehacker.com's todo.sh script for maintaining a todo.txt file
+
+# Contributor: David Rosenstrauch <darose@darose.net>
+
+pkgname=todotxt
+_pkgname=todo.txt_cli
+pkgver=2.10
+pkgrel=2
+pkgdesc="lifehacker.com's todo.sh script for maintaining a todo.txt file"
+url="http://ginatrapani.github.com/todo.txt-cli/"
+depends=('bash')
+install=$pkgname.install
+source=(https://github.com/ginatrapani/todo.txt-cli/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz)
+md5sums=('d90098b5f031d117faf129a4c90e812d')
+arch=('any')
+license="GPL"
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ install -D -m644 todo.cfg $pkgdir/usr/share/$pkgname/todo.cfg
+ install -D -m755 todo.sh $pkgdir/usr/bin/todo.sh
+
+ install -d $pkgdir/usr/share/bash-completion/completions/
+ install -D -m644 todo_completion $pkgdir/usr/share/bash-completion/completions/todo.sh
+}
diff --git a/todotxt.install b/todotxt.install
new file mode 100644
index 000000000000..745117a68bc4
--- /dev/null
+++ b/todotxt.install
@@ -0,0 +1,17 @@
+# arg 1: the new package version
+post_install() {
+ echo
+ echo "Please copy the file /usr/share/todotxt/todo.cfg to ~/.todo.cfg"
+ echo "and then edit the TODO_DIR path in that file to your desired todo data directory."
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo "Please note that the config file has changed from ~/.todo to ~/.todo.cfg,"
+ echo "and the config file contents have changed slightly since the previous release."
+ echo
+ echo "Please copy the file /usr/share/todotxt/todo.cfg to ~/.todo.cfg"
+ echo "and then edit the TODO_DIR path in that file to your desired todo data directory."
+ echo
+}