summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77c03df6b590..105cf4054d21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = todotxt
pkgdesc = Simple and extensible shell script for managing your todo.txt file
pkgver = 2.12.0.post1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/todotxt/todo.txt-cli
install = todotxt.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 7dc8c9bd852d..c01f419c6ba5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=todotxt
#pkgver=2.12.0
pkgver=2.12.0.post1
-pkgrel=2
+pkgrel=3
pkgdesc="Simple and extensible shell script for managing your todo.txt file"
arch=('any')
url="https://github.com/todotxt/todo.txt-cli"
@@ -20,18 +20,14 @@ source=($pkgname-$pkgver::git+$url.git#commit=77c1f34609070135143f29395edc647a2d
sha256sums=('SKIP')
build() {
- #cd $_srcname-$pkgver
- cd $pkgname-$pkgver
- make
+ make -C $pkgname-$pkgver
}
check() {
- cd $pkgname-$pkgver
- make test
+ make -C $pkgname-$pkgver test
}
package() {
- cd $pkgname-$pkgver
- make install CONFIG_DIR=$pkgdir/etc INSTALL_DIR=$pkgdir/usr/bin BASH_COMPLETION=$pkgdir/usr/share/bash-completion/completions
+ make -C $pkgname-$pkgver install CONFIG_DIR=$pkgdir/etc INSTALL_DIR=$pkgdir/usr/bin BASH_COMPLETION=$pkgdir/usr/share/bash-completion/completions
}