summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa3a617f8c1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tofrodos
+ pkgdesc = Convert ASCII files between the MS-DOS/Windows format and the UNIX format
+ pkgver = 1.7.13
+ pkgrel = 2
+ url = http://www.thefreecountry.com/tofrodos/index.shtml
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ conflicts = dos2unix
+ conflicts = hd2u
+ source = http://tofrodos.sourceforge.net/download/tofrodos-1.7.13.tar.gz
+ md5sums = c4c5e6668a13a01bfb5ce562753a808f
+
+pkgname = tofrodos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a4559c5af782
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Contributor: Nick Smallbone <nick.smallbone@gmail.com>
+
+pkgname=tofrodos
+pkgver=1.7.13
+pkgrel=2
+arch=('i686' 'x86_64')
+pkgdesc="Convert ASCII files between the MS-DOS/Windows format and the UNIX format"
+url="http://www.thefreecountry.com/tofrodos/index.shtml"
+license=('GPL2')
+conflicts=('dos2unix' 'hd2u')
+depends=('glibc')
+source=(http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz)
+md5sums=('c4c5e6668a13a01bfb5ce562753a808f')
+
+build() {
+ export CFLAGS+=" -c -Wall"
+ cd "$pkgname/src"
+ make -e
+}
+
+package() {
+ cd "$pkgname/src"
+ install -d "$pkgdir"/usr/{bin,share/man/man1}
+ make BINDIR="$pkgdir/usr/bin" MANDIR="$pkgdir/usr/share/man/man1" install
+ ln -s todos "$pkgdir/usr/bin/unix2dos"
+ ln -s fromdos "$pkgdir/usr/bin/dos2unix"
+}