summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD66
3 files changed, 35 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 269034576c2b..3a77f635d5ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,25 @@
pkgbase = toggldesktop-git
pkgdesc = Toggl time tracking software
- pkgver = 7.5.33.r0.g206717021
+ pkgver = 7.5.473.r0.g322fb942e
pkgrel = 1
url = https://github.com/toggl-open-source/toggldesktop
arch = x86_64
license = BSD
makedepends = cmake
- makedepends = ninja
- depends = libxss
- depends = qt5-base
+ makedepends = git
+ depends = jsoncpp
+ depends = lua
+ depends = poco
+ depends = qt5-networkauth
depends = qt5-webengine
depends = qt5-x11extras
- depends = openssl
- depends = poco
- depends = lua
- depends = jsoncpp
provides = toggldesktop
conflicts = toggldesktop
conflicts = toggldesktop-bin
conflicts = toggl-bin
- source = toggldesktop::git+https://github.com/toggl-open-source/toggldesktop.git
+ source = toggldesktop::git+https://github.com/toggl-open-source/toggldesktop
source = jsoncpp.patch
sha512sums = SKIP
sha512sums = 05813df185163e1361d99cf24291bd44bdfefeee050b56f2923fb909c2c57d532e0a459cdaea96504ed10d27004fe3ee9f3c34ec35bcc9f9f2e064cccd8cfe77
pkgname = toggldesktop-git
-
diff --git a/.gitignore b/.gitignore
index 86702b8e8344..8783ef89eab0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.pkg.*
src/
pkg/
-toggldesktop/ \ No newline at end of file
+toggldesktop/
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 0a83f100d434..0edd73dee720 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,35 +5,31 @@
# Contributor: phi-mah
pkgname=toggldesktop-git
-_pkgname=toggldesktop
-pkgver=7.5.33.r0.g206717021
+_pkgname="${pkgname%-*}"
+pkgver=7.5.473.r0.g322fb942e
pkgrel=1
pkgdesc="Toggl time tracking software"
arch=('x86_64')
url="https://github.com/toggl-open-source/toggldesktop"
license=('BSD')
depends=(
- 'libxss'
- 'qt5-base'
+ 'jsoncpp'
+ 'lua'
+ 'poco'
+ 'qt5-networkauth'
'qt5-webengine'
'qt5-x11extras'
- 'openssl'
- 'poco'
- 'lua'
- 'jsoncpp'
)
-makedepends=('cmake' 'ninja')
+makedepends=(
+ 'cmake'
+ 'git'
+)
conflicts=("${_pkgname}" "${_pkgname}-bin" 'toggl-bin')
provides=("${_pkgname}")
-source=(
- "${_pkgname}::git+https://github.com/toggl-open-source/toggldesktop.git"
- "jsoncpp.patch"
-)
-
-sha512sums=(
- 'SKIP'
- '05813df185163e1361d99cf24291bd44bdfefeee050b56f2923fb909c2c57d532e0a459cdaea96504ed10d27004fe3ee9f3c34ec35bcc9f9f2e064cccd8cfe77'
-)
+source=("${_pkgname}::git+$url"
+ "jsoncpp.patch")
+sha512sums=('SKIP'
+ '05813df185163e1361d99cf24291bd44bdfefeee050b56f2923fb909c2c57d532e0a459cdaea96504ed10d27004fe3ee9f3c34ec35bcc9f9f2e064cccd8cfe77')
pkgver() {
cd "${_pkgname}"
@@ -41,36 +37,26 @@ pkgver() {
}
prepare() {
- cd "${_pkgname}"
-
- # patch to build
- patch -p1 < ../jsoncpp.patch
+ cd "${_pkgname}"
- # although removing _build folder in build() function feels more natural,
- # that interferes with the spirit of makepkg --noextract
- if [ -d _build ]; then
- rm -rf _build
- fi
+ patch -p1 < ../jsoncpp.patch
}
build() {
- mkdir -p _build && cd _build
- cmake ../${_pkgname} \
- -G Ninja \
- -DCMAKE_INSTALL_PREFIX=/usr\
- -DTOGGL_VERSION:STRING="${pkgver}"\
- -DTOGGL_PRODUCTION_BUILD=ON\
- -DTOGGL_ALLOW_UPDATE_CHECK=ON\
+ cmake -S "${_pkgname}" \
+ -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DTOGGL_VERSION:STRING="${pkgver}" \
+ -DTOGGL_PRODUCTION_BUILD=ON \
+ -DTOGGL_ALLOW_UPDATE_CHECK=ON \
-DUSE_BUNDLED_LIBRARIES=OFF
- ninja
+
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" ninja -C _build install
-
- cd "${_pkgname}"
+ DESTDIR="${pkgdir}" cmake --install build
- # license file in standard location
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 ${_pkgname}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}