summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
2 files changed, 21 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c14462267cc..2a47db44fc37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = tokyocabinet-git
pkgdesc = a modern implementation of DBM
- pkgver = 1.4.48.r15.gd303368
+ pkgver = 1.4.48.r20.g6d4cc70
pkgrel = 1
- url = http://fallabs.com/tokyocabinet/
+ url = http://fallabs.com/tokyocabinet
arch = i686
arch = x86_64
arch = armv7h
license = LGPL
- makedepends = gcc>=3.1
+ makedepends = gcc
makedepends = make
makedepends = pkgconfig
makedepends = git
@@ -15,8 +15,7 @@ pkgbase = tokyocabinet-git
depends = bzip2
provides = tokyocabinet=1.4.48
conflicts = tokyocabinet
- source = tokyocabinet-git::git+git://github.com/Incubaid/tokyocabinet
- md5sums = SKIP
+ source = git+https://github.com/Incubaid/tokyocabinet
+ sha512sums = SKIP
pkgname = tokyocabinet-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bffa0b0e31a8..3109da53e6ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,40 @@
-# Maintainer: Vincent Bernardoff <vb@luminar.eu.org>
+# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
# Contributor: Mark Foxwell <fastfret79@archlinux.org.uk>
# Contributor: Nicolas Martyanoff <khaelin@gmail.com>
# Contributor: Rick Chen <stuffcorpse@archlinux.us>
-
-pkgname=tokyocabinet-git
-pkgver=1.4.48.r15.gd303368
+_base=tokyocabinet
+pkgname=${_base}-git
+pkgver=1.4.48.r20.g6d4cc70
pkgrel=1
pkgdesc="a modern implementation of DBM"
arch=('i686' 'x86_64' 'armv7h')
-url="http://fallabs.com/tokyocabinet/"
-license=('LGPL')
-makedepends=('gcc>=3.1' 'make' 'pkgconfig' 'git')
-depends=('zlib' 'bzip2')
-source=("$pkgname"::'git+git://github.com/Incubaid/tokyocabinet')
-conflicts=('tokyocabinet')
-provides=('tokyocabinet=1.4.48')
-md5sums=('SKIP')
+url="http://fallabs.com/${_base}"
+license=(LGPL)
+depends=(zlib bzip2)
+makedepends=(gcc make pkgconfig git)
+source=(git+https://github.com/Incubaid/${_base})
+conflicts=(${_base})
+provides=("${_base}=1.4.48")
+sha512sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd ${_base}
git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$pkgname"
+ cd ${_base}
./configure --prefix=/usr --enable-off64
make
}
# uncomment check routine if needed (can take ~5mins to run check)
# check() {
-# cd "$srcdir/$pkgname"
+# cd ${_base}
# make -k check
# }
package() {
- cd "$srcdir/$pkgname"
+ cd ${_base}
make DESTDIR="$pkgdir/" install
}
-
-# vim:set ts=2 sw=2 et: