summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD52
2 files changed, 58 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cb6b106f967..3fe6dd19ee84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,38 @@
pkgbase = tomate-gtk
- pkgdesc = A timer for the Pomodoro Technique
- pkgver = 0.10.0
- pkgrel = 1
+ pkgdesc = A Pomodoro timer
+ pkgver = 0.25.0
+ pkgrel = 6
url = https://github.com/eliostvs/tomate-gtk
install = tomate-gtk.install
arch = any
license = GPL
makedepends = python-setuptools
depends = desktop-file-utils
+ depends = gnome-icon-theme
depends = gtk-update-icon-cache
depends = gtk3
depends = hicolor-icon-theme
+ depends = hicolor-icon-theme
+ depends = libnotify
+ depends = playerctl
depends = python
- depends = python-tomate
+ depends = python-blinker
+ depends = python-dbus
+ depends = python-gobject
+ depends = python-pyxdg
+ depends = python-venusian
+ depends = python-wiring
+ depends = python-wrapt
+ depends = python-yapsy
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gstreamer
+ conflicts = tomate-breakscreen-plugin
+ conflicts = tomate-alarm-plugin
+ conflicts = tomate-exec-plugin
+ conflicts = tomate-notify-plugin
options = !emptydirs
- source = https://github.com/eliostvs/tomate-gtk/archive/0.10.0.tar.gz
- md5sums = 77ece53a9d87eba5db05dfd428691f61
+ source = https://github.com/eliostvs/tomate-gtk/archive/0.25.0.tar.gz
+ md5sums = 8ade6ca500e3776fc226700b207fa785
pkgname = tomate-gtk
-
diff --git a/PKGBUILD b/PKGBUILD
index e89329f7a1a2..107760122c63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,42 @@
# Maintainer: Elio Esteves Duarte <elio.esteves.duarte@gmail.com>
pkgname=tomate-gtk
-pkgver=0.10.0
-pkgrel=1
-pkgdesc="A timer for the Pomodoro Technique"
-arch=('any')
+pkgver=0.25.0
+pkgrel=6
+pkgdesc="A Pomodoro timer"
+arch=("any")
url="https://github.com/eliostvs/tomate-gtk"
-license=('GPL')
-depends=('desktop-file-utils'
- 'gtk-update-icon-cache'
- 'gtk3'
- 'hicolor-icon-theme'
- 'python'
- 'python-tomate')
-optdependes=('tomate-alarm-plugin: Plays alarm at session end'
- 'tomate-indicator-plugin: Shows session progress in tray area'
- 'tomate-notify-plugin: Plugin that shows screen notifications'
- 'tomate-exec-plugin: Run commands when timer starts, stops or finishes'
- 'tomate-statusicon-plugin: Plugin that shows the session progress in the notification area')
-makedepends=('python-setuptools')
+license=("GPL")
+depends=("desktop-file-utils"
+ "gnome-icon-theme"
+ "gtk-update-icon-cache"
+ "gtk3"
+ "hicolor-icon-theme"
+ "hicolor-icon-theme"
+ "libnotify"
+ "playerctl"
+ "python"
+ "python-blinker"
+ "python-dbus"
+ "python-gobject"
+ "python-pyxdg"
+ "python-venusian"
+ "python-wiring"
+ "python-wrapt"
+ "python-yapsy"
+ "gst-plugins-base"
+ "gst-plugins-good"
+ "gstreamer")
+optdependes=("tomate-indicator-plugin: Displays the progress of the session in system tray"
+ "tomate-statusnotifieritem-plugin: Displays the progress of the session in system tray"
+ "tomate-statusicon-plugin: Displays the progress of the session in system tray")
+makedepends=("python-setuptools")
options=(!emptydirs)
source=("https://github.com/eliostvs/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('77ece53a9d87eba5db05dfd428691f61')
+md5sums=('8ade6ca500e3776fc226700b207fa785')
+conflicts=("tomate-breakscreen-plugin"
+ "tomate-alarm-plugin"
+ "tomate-exec-plugin"
+ "tomate-notify-plugin")
install=tomate-gtk.install
package() {