summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
-rw-r--r--tomate-indicator-plugin.install11
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a41c3bd8a41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Jan 23 17:45:04 UTC 2016
+pkgbase = tomate-indicator-plugin
+ pkgdesc = Tomate plugin that shows the session progress in indicator
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/eliostvs/tomate-gtk
+ install = tomate-indicator-plugin.install
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = gtk-update-icon-cache
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk3
+ depends = python
+ depends = tomate-gtk
+ options = !emptydirs
+ source = https://github.com/eliostvs/tomate-indicator-plugin/archive/0.4.1.tar.gz
+
+pkgname = tomate-indicator-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1942abd7722
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Elio Esteves Duarte <elio.esteves.duarte@gmail.com>
+pkgname=tomate-indicator-plugin
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Tomate plugin that shows the session progress in indicator"
+arch=('any')
+url="https://github.com/eliostvs/tomate-gtk"
+license=('GPL')
+depends=('gtk-update-icon-cache'
+ 'gtk3'
+ 'hicolor-icon-theme'
+ 'libappindicator-gtk3'
+ 'python'
+ 'tomate-gtk')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://github.com/eliostvs/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('')
+install=tomate-indicator-plugin.install
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/tomate-indicator-plugin.install b/tomate-indicator-plugin.install
new file mode 100644
index 000000000000..f46ccdc5ee50
--- /dev/null
+++ b/tomate-indicator-plugin.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file