summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch17
-rw-r--r--0001-tomatoes-1.55-makefile-compile-flags.patch31
-rw-r--r--PKGBUILD18
4 files changed, 42 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afac9bfff1bf..0748058f34f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tomatoes
pkgdesc = How many tomatoes can you smash in ten short minutes?
pkgver = 1.55
- pkgrel = 14
+ pkgrel = 15
url = http://tomatoes.sourceforge.net
arch = i686
arch = x86_64
@@ -12,12 +12,12 @@ pkgbase = tomatoes
depends = glu
source = https://downloads.sourceforge.net/tomatoes/tomatoes-linux-src-1.55.tar.bz2
source = https://downloads.sourceforge.net/tomatoes/tomatoes-linux-1.5.tar.bz2
- source = 0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch
+ source = 0001-tomatoes-1.55-makefile-compile-flags.patch
source = 0002-tomatoes-1.55-Quell-const-char-conversion-warnings.patch
source = 0003-tomatoes-1.55-config-hiscore-file-saving-loading.patch
sha256sums = 126d001532ee5b81cc95e1a86a274d11669b8c8f65c8235ae2e9b8fbdfab4a60
sha256sums = 69a3af1994cb58409be9b469e1aa4bdb91c405d99071c7431526640ec53d1300
- sha256sums = 49b2944b268efcfc660da682dfbc2404558e52ba034cc39d310e8c74ed89646c
+ sha256sums = 61c03349398ba56a9781a79a9c8ae962f870b25d9b0ddeb36f5e662a6cb90ff2
sha256sums = 4f9e72fcb3d4427ec633d9ce6f3bb73179cfac1dba55f1ff7f68725f63f1d55d
sha256sums = 0dcab19428d4904d1d5ab0099b23f6d9f3f53399303166ad3cea6e743efcd9bf
diff --git a/0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch b/0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch
deleted file mode 100644
index 4b9f49c0da3f..000000000000
--- a/0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Subject: makefile: Append to compile flags.
-From: Loui Chang <louipc.ist@gmail.com>
-
-Reported-by: Andreas Hauser <andy-aur@splashground.de>
---- a/makefile 2004-11-20 13:50:09.000000000 -0500
-+++ b/makefile 2008-06-12 11:59:57.000000000 -0400
-@@ -47,8 +47,8 @@
- CFLAGS = -MMD -g3 -O3 -march=$(MARCH) -Wall -pg
- LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -pg
- else
--CFLAGS = -MMD -O3 -march=$(MARCH) -Wall $(SDL_FLAGS)
--LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -s
-+CFLAGS += -MMD $(SDL_FLAGS)
-+LDFLAGS += $(sdl-config --libs) -lSDL_image -lSDL_mixer -lGL -lGLU -s
- endif
- endif
-
diff --git a/0001-tomatoes-1.55-makefile-compile-flags.patch b/0001-tomatoes-1.55-makefile-compile-flags.patch
new file mode 100644
index 000000000000..66e851ca45a0
--- /dev/null
+++ b/0001-tomatoes-1.55-makefile-compile-flags.patch
@@ -0,0 +1,31 @@
+--- a/makefile 2017-09-16 09:14:06.399502208 +0200
++++ b/makefile 2017-09-16 09:14:13.459372215 +0200
+@@ -35,7 +35,7 @@
+
+
+ # SDL flags
+-SDL_FLAGS = `sdl-config --cflags`
++SDL_FLAGS = $(shell sdl-config --cflags)
+
+
+ # Debugmode stuff
+@@ -47,8 +47,8 @@
+ CFLAGS = -MMD -g3 -O3 -march=$(MARCH) -Wall -pg
+ LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -pg
+ else
+-CFLAGS = -MMD -O3 -march=$(MARCH) -Wall $(SDL_FLAGS)
+-LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -s
++CXXFLAGS += -MMD $(SDL_FLAGS)
++LDFLAGS += $(shell sdl-config --libs) -lSDL_image -lSDL_mixer -lGL -lGLU
+ endif
+ endif
+
+@@ -80,7 +80,7 @@
+ rebuild: veryclean all
+
+ obj/%.o: src/%.cpp
+- $(CC) $(CFLAGS) $(INCLUDES) $(DIR_DEFINES) -c $< -o $@
++ $(CC) $(CXXFLAGS) $(CPPFLAGS) $(INCLUDES) $(DIR_DEFINES) -c $< -o $@
+
+ # Compress the exe with UPX
+ compress: $(TARGET)
diff --git a/PKGBUILD b/PKGBUILD
index 1dfe3d415665..693dc3f6eab2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=tomatoes
pkgver=1.55
-pkgrel=14
+pkgrel=15
pkgdesc="How many tomatoes can you smash in ten short minutes?"
url="http://tomatoes.sourceforge.net"
license=('ZLIB')
@@ -12,21 +12,21 @@ depends=('sdl_image' 'sdl_mixer' 'glu')
makedepends=('gendesk')
source=("https://downloads.sourceforge.net/$pkgname/$pkgname-linux-src-$pkgver.tar.bz2"
"https://downloads.sourceforge.net/$pkgname/$pkgname-linux-1.5.tar.bz2"
- "0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch"
+ "0001-tomatoes-1.55-makefile-compile-flags.patch"
"0002-tomatoes-1.55-Quell-const-char-conversion-warnings.patch"
"0003-tomatoes-1.55-config-hiscore-file-saving-loading.patch")
sha256sums=('126d001532ee5b81cc95e1a86a274d11669b8c8f65c8235ae2e9b8fbdfab4a60'
'69a3af1994cb58409be9b469e1aa4bdb91c405d99071c7431526640ec53d1300'
- '49b2944b268efcfc660da682dfbc2404558e52ba034cc39d310e8c74ed89646c'
+ '61c03349398ba56a9781a79a9c8ae962f870b25d9b0ddeb36f5e662a6cb90ff2'
'4f9e72fcb3d4427ec633d9ce6f3bb73179cfac1dba55f1ff7f68725f63f1d55d'
'0dcab19428d4904d1d5ab0099b23f6d9f3f53399303166ad3cea6e743efcd9bf')
prepare() {
cd $pkgname-$pkgver
- patch -p1 < ../0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch
- patch -p1 < ../0002-tomatoes-1.55-Quell-const-char-conversion-warnings.patch
- patch -p0 < ../0003-tomatoes-1.55-config-hiscore-file-saving-loading.patch
+ patch -p1 -i ../0001-tomatoes-1.55-makefile-compile-flags.patch
+ patch -p1 -i ../0002-tomatoes-1.55-Quell-const-char-conversion-warnings.patch
+ patch -p0 -i ../0003-tomatoes-1.55-config-hiscore-file-saving-loading.patch
sed -n '7,27p' README-src > LICENSE
@@ -37,8 +37,6 @@ prepare() {
build() {
cd $pkgname-$pkgver
- LDFLAGS=/usr/lib/libSDL-1.2.so.0
-
make \
MPKDIR=/usr/share/tomatoes/ \
MUSICDIR=/usr/share/tomatoes/music/ \
@@ -49,8 +47,8 @@ build() {
package() {
cd $pkgname-$pkgver
- install -d "$pkgdir"/usr/share/$pkgname
- cp -r ../$pkgname-1.5/* "$pkgdir"/usr/share/$pkgname
+ install -d "$pkgdir"/usr/share/tomatoes
+ cp -r ../tomatoes-1.5/* "$pkgdir"/usr/share/tomatoes
install -Dm755 tomatoes "$pkgdir"/usr/bin/tomatoes
install -Dm644 icon.png "$pkgdir"/usr/share/pixmaps/tomatoes.png