summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
-rw-r--r--tong.desktop2
3 files changed, 29 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e09693b245e6..e7271a74bd22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = tong
pkgdesc = Tetris meets Pong, with more twists than a contortionist club's secret handshake
pkgver = 1.3
- pkgrel = 4
- url = http://tong.nongnu.org/
+ pkgrel = 5
+ url = https://tong.nongnu.org/
arch = i686
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
+ depends = gcc-libs
+ depends = glibc
depends = sdl_image
depends = sdl_mixer
- source = http://www.nongnu.org/tong/tong-1.3.tar.gz
+ depends = sdl12-compat
+ source = http://tong.nongnu.org/tong-1.3.tar.gz
source = tong.desktop
md5sums = a9d70c7b2f637e9d95e6fbdf6d22782d
- md5sums = 90695390ee1c4fd907a00beedb1e651d
+ md5sums = 4c99f05484e5c60708fd14272af2e357
pkgname = tong
-
diff --git a/PKGBUILD b/PKGBUILD
index 44aaea6263c6..cb43189e134f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,36 @@
pkgname='tong'
pkgver='1.3'
-pkgrel='4'
+pkgrel='5'
pkgdesc="Tetris meets Pong, with more twists than a contortionist club's secret handshake"
arch=('i686' 'x86_64')
-url="http://tong.nongnu.org/"
-license=('GPL3')
-depends=('sdl_image' 'sdl_mixer')
-source=("http://www.nongnu.org/tong/$pkgname-$pkgver.tar.gz"
+url="https://tong.nongnu.org/"
+license=('GPL-3.0-or-later')
+depends=('gcc-libs' 'glibc' 'sdl_image' 'sdl_mixer' 'sdl12-compat')
+source=("http://tong.nongnu.org/$pkgname-$pkgver.tar.gz"
"$pkgname.desktop")
md5sums=('a9d70c7b2f637e9d95e6fbdf6d22782d'
- '90695390ee1c4fd907a00beedb1e651d')
+ '4c99f05484e5c60708fd14272af2e357')
build() {
- cd $srcdir/$pkgname
- make GAME_DATA_DIR=/usr/share/$pkgname
+ cd "$srcdir/$pkgname"
+ make GAME_DATA_DIR="/usr/share/$pkgname"
}
package() {
- mkdir -p $pkgdir/usr/share/$pkgname
+ mkdir -p "$pkgdir/usr/share/$pkgname"
- #copy files and binary on appropriate destinations
- cd $srcdir/$pkgname
- cp -r media $pkgdir/usr/share/$pkgname/
- install -m644 CREDITS $pkgdir/usr/share/$pkgname/CREDITS
- install -Dm644 README $pkgdir/usr/share/doc/$pkgname/README
- install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+ # Copy files and binary on appropriate destinations
+ cd "$srcdir/$pkgname"
+ cp -r media "$pkgdir/usr/share/$pkgname/"
+ install -m644 CREDITS "$pkgdir/usr/share/$pkgname/CREDITS"
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- #remove unneeded folders
- rm -r $pkgdir/usr/share/$pkgname/media/{gp2x,wii}
+ # Remove unneeded folders
+ rm -r "$pkgdir/usr/share/$pkgname/media/"{gp2x,wii}
- #install a desktop entry
- install -Dm644 media/icon.png $pkgdir/usr/share/pixmaps/$pkgname.png
- install -Dm644 ../$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ # Install a desktop entry
+ install -Dm644 media/icon.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "../$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}
diff --git a/tong.desktop b/tong.desktop
index f0869e74adc3..a7b898f68366 100644
--- a/tong.desktop
+++ b/tong.desktop
@@ -6,4 +6,4 @@ Icon=/usr/share/pixmaps/tong.png
Terminal=false
Type=Application
StartupNotify=true
-Categories=Game;ArcadeGame;
+Categories=Game