summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be73a41ee1ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = toosheh
+ pkgdesc = An unofficial and open-source toosheh client for Linux written in C++. Please USE A VPN or any anti-sensorship tool before installing this program.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.toosheh.org/
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ makedepends = gcc
+ makedepends = gtkmm3
+ depends = toosheh-extractor
+ depends = gtkmm3
+ depends = coreutils
+ depends = grep
+ provides = toosheh
+ conflicts = toosheh
+ source = https://gitlab.com/toosheh/toosheh-for-linux/-/archive/1.0.0/toosheh-for-linux-1.0.0.tar.gz
+ md5sums = SKIP
+
+pkgname = toosheh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb267b871106
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Master81 <FreeFighter81@protonmail.com>
+
+pkgname=toosheh
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="An unofficial and open-source toosheh client for Linux written in C++. Please USE A VPN or any anti-sensorship tool before installing this program."
+url="https://www.toosheh.org/"
+arch=(x86_64 aarch64)
+license=(GPL)
+depends=(toosheh-extractor gtkmm3 coreutils grep)
+makedepends=(gcc gtkmm3)
+conflicts=(toosheh)
+provides=(toosheh)
+source=("https://gitlab.com/toosheh/toosheh-for-linux/-/archive/${pkgver}/toosheh-for-linux-${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/toosheh-for-linux-${pkgver}/resource
+ glib-compile-resources --target=resources.c --generate-source resources.xml
+ cd ..
+ g++ -rdynamic src/main.cpp resource/resources.c -o toosheh `pkg-config gtkmm-3.0 --libs --cflags`
+}
+
+package() {
+ cd $srcdir/toosheh-for-linux-${pkgver}
+ #install executable
+ install -d $pkgdir/usr/bin
+ install -Dm755 toosheh $pkgdir/usr/bin/toosheh
+ #integrate shortcut...
+ install -d $pkgdir/usr/share/applications
+ install -Dm644 resource/desktop/toosheh.desktop $pkgdir/usr/share/applications/toosheh.desktop
+ #integrate icons...
+ install -d $pkgdir/usr/share/icons/hicolor/
+ for res in 32 48 64 128 192 256; do
+ install -d $pkgdir/usr/share/icons/hicolor/${res}x${res}/apps
+ install -m644 resource/image/icons/${res}x${res}/toosheh.png $pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/toosheh.png
+ done
+}