summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5d18fb3e14d..08ef3d7cc3d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = toot
pkgdesc = a Mastodon CLI client
- pkgver = 0.25.0
+ pkgver = 0.38.1
pkgrel = 1
url = https://github.com/ihabunek/toot
arch = any
license = GPL3
+ makedepends = python-setuptools
depends = python-requests
depends = python-beautifulsoup4
depends = python-wcwidth
depends = python-urwid
- source = https://files.pythonhosted.org/packages/source/t/toot/toot-0.25.0.tar.gz
- sha256sums = eac52d728750aca6cd9985f5fb5dc4d4564b40bdfbf5bcbbbeacf38ae3114a46
+ depends = python-tomlkit
+ source = https://github.com/ihabunek/toot/archive/0.38.1.zip
+ sha256sums = dab271f657f45c6f1ec1dcc5c0a42dbe533f237422d88d8f9b91f8f33a1f56c8
pkgname = toot
-
diff --git a/PKGBUILD b/PKGBUILD
index 05562371f41d..a5b3f5c2e914 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
pkgname=toot
_name=toot
-pkgver=0.25.0
+pkgver=0.38.1
pkgrel=1
pkgdesc="a Mastodon CLI client"
-depends=('python-requests' 'python-beautifulsoup4' 'python-wcwidth' 'python-urwid')
+makedepends=('python-setuptools')
+depends=('python-requests' 'python-beautifulsoup4' 'python-wcwidth' 'python-urwid' 'python-tomlkit')
license=('GPL3')
arch=('any')
url="https://github.com/ihabunek/toot"
-source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz)
-sha256sums=('eac52d728750aca6cd9985f5fb5dc4d4564b40bdfbf5bcbbbeacf38ae3114a46')
+source=(https://github.com/ihabunek/${_name}/archive/${pkgver}.zip)
+sha256sums=('dab271f657f45c6f1ec1dcc5c0a42dbe533f237422d88d8f9b91f8f33a1f56c8')
build() {
cd "$pkgname-$pkgver"
@@ -19,7 +20,6 @@ package() {
cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- rm $pkgdir/usr/CHANGELOG.md
mkdir -p $pkgdir/usr/share/licenses/toot
- mv $pkgdir/usr/LICENSE $pkgdir/usr/share/licenses/toot/
+ cp $srcdir/$pkgname-$pkgver/LICENSE $pkgdir/usr/share/licenses/toot/
}