summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef350854312e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = toot
+ pkgdesc = a Mastodon CLI client
+ pkgver = 0.19.0
+ pkgrel = 1
+ url = https://github.com/ihabunek/toot
+ arch = any
+ license = GPL3
+ source = https://files.pythonhosted.org/packages/source/t/toot/toot-0.19.0.tar.gz
+ sha256sums = 857adc08ed2531c934a69d64efc78cd96bca80dd0a2b41e9033bdd61a50d6ffd
+
+pkgname = toot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e2fc9bde7c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=toot
+_name=toot
+pkgver=0.19.0
+pkgrel=1
+pkgdesc="a Mastodon CLI client"
+license=('GPL3')
+arch=('any')
+url="https://github.com/ihabunek/toot"
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz)
+sha256sums=('857adc08ed2531c934a69d64efc78cd96bca80dd0a2b41e9033bdd61a50d6ffd')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}