summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--Application-make-app_entries-private.patch26
-rw-r--r--PKGBUILD7
3 files changed, 34 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c6ef642daeb..244338f5279d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tootle
pkgdesc = GTK3 client for Mastodon
pkgver = 1.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/bleakgrey/tootle
arch = x86_64
arch = aarch64
@@ -28,8 +28,10 @@ pkgbase = tootle
source = https://github.com/bleakgrey/tootle/archive/1.0.tar.gz
source = Use-reason_phrase-instead-of-get_phrase.patch
source = Adhere-to-GLib.Object-naming-conventions.patch
+ source = Application-make-app_entries-private.patch
sha256sums = e0a0a062b1b72010242f7bb4db97cd71190f23067188b5c07372264d768a0496
sha256sums = 06314649f967661defaf5d847a9ecdf4b942299a08613c4f3087afa6ecf5d7fc
sha256sums = 84962b788787c075fadaf2fe4e56f104340b6f1386c889df03455a67fcc5f779
+ sha256sums = 54baf63d378444e37a5bbfb8087fea5fc9c0bf90c67b0bde568b41c121f00660
pkgname = tootle
diff --git a/Application-make-app_entries-private.patch b/Application-make-app_entries-private.patch
new file mode 100644
index 000000000000..31edff72ea88
--- /dev/null
+++ b/Application-make-app_entries-private.patch
@@ -0,0 +1,26 @@
+From ee278f143f307dd1396afe3eb79237a027cc7b90 Mon Sep 17 00:00:00 2001
+From: Bobby Rong <rjl931189261@126.com>
+Date: Sat, 19 Mar 2022 16:59:31 +0800
+Subject: [PATCH] Application: make app_entries private
+
+Fixes compilation with latest valac.
+---
+ src/Application.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Application.vala b/src/Application.vala
+index 3b2c9b9..09556bb 100644
+--- a/src/Application.vala
++++ b/src/Application.vala
+@@ -43,7 +43,7 @@ namespace Tootle {
+ { null }
+ };
+
+- public const GLib.ActionEntry[] app_entries = {
++ private const GLib.ActionEntry[] app_entries = {
+ { "about", about_activated },
+ { "compose", compose_activated },
+ { "back", back_activated },
+--
+2.35.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 7af8eeaf61cf..88d08ddc6504 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=tootle
pkgver=1.0
_pkgver=${pkgver//_/-}
-pkgrel=5
+pkgrel=6
pkgdesc="GTK3 client for Mastodon"
arch=('x86_64' 'aarch64')
url="https://github.com/bleakgrey/tootle"
@@ -37,16 +37,19 @@ source=(
"https://github.com/bleakgrey/$pkgname/archive/${_pkgver}.tar.gz"
"Use-reason_phrase-instead-of-get_phrase.patch"
"Adhere-to-GLib.Object-naming-conventions.patch"
+ "Application-make-app_entries-private.patch"
)
sha256sums=('e0a0a062b1b72010242f7bb4db97cd71190f23067188b5c07372264d768a0496'
'06314649f967661defaf5d847a9ecdf4b942299a08613c4f3087afa6ecf5d7fc'
- '84962b788787c075fadaf2fe4e56f104340b6f1386c889df03455a67fcc5f779')
+ '84962b788787c075fadaf2fe4e56f104340b6f1386c889df03455a67fcc5f779'
+ '54baf63d378444e37a5bbfb8087fea5fc9c0bf90c67b0bde568b41c121f00660')
build() {
cd "${srcdir}/${pkgname}-${_pkgver}"
patch -p1 < "$startdir/Use-reason_phrase-instead-of-get_phrase.patch"
patch -p1 < "$startdir/Adhere-to-GLib.Object-naming-conventions.patch"
+ patch -p1 < "$startdir/Application-make-app_entries-private.patch"
arch-meson build
ninja -C build