summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD98
-rw-r--r--TrrntZip.NET3
-rw-r--r--TrrntZipUI3
-rw-r--r--torrentzip.net-git-fix-case.patch12
-rw-r--r--torrentzip.net-git-linux-fix.patch40
-rw-r--r--torrentzip.net-git-no-ilmerge.patch40
-rw-r--r--torrentzip.net.desktop11
8 files changed, 238 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3837d435a86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = torrentzip.net-git
+ pkgdesc = Torrentzip utility with mutli core processing capability (git version)
+ pkgver = r17.7513f4e
+ pkgrel = 1
+ url = http://www.romvault.com/trrntzip/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = imagemagick
+ depends = mono
+ depends = sh
+ depends = hicolor-icon-theme
+ provides = torrentip.net
+ conflicts = torrentip.net
+ source = git+https://github.com/RomVault/RVWorld.git
+ source = TrrntZip.NET
+ source = TrrntZipUI
+ source = torrentzip.net.desktop
+ source = torrentzip.net-git-no-ilmerge.patch
+ source = torrentzip.net-git-fix-case.patch
+ source = torrentzip.net-git-linux-fix.patch
+ sha256sums = SKIP
+ sha256sums = fcec85063da4f78dc853f443493709458ae627aaf8968476c7ea02056b0982b0
+ sha256sums = af32f3a2609a9eae37a2c836b0a4961230cfdffec6080d23fc94c5a0c4a181f0
+ sha256sums = ab1f7bd79b7f255ee93b7986e3b8674eb32150c1043e349f351db2c29788aebe
+ sha256sums = 6173068d16ca19f6b8e29cf176d0633a5b4a81b2986bd36a85e0fe5fa095a9f6
+ sha256sums = 5f54911530550c5e4379422cbacea6258c7a0e07429b3530a12a6daad157585e
+ sha256sums = 170fc46eb2af90ad47a76bbc3827219f024fe9b5df95b317202396ec299ae06d
+
+pkgname = torrentzip.net-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d7e1a75c45c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,98 @@
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+
+pkgname=torrentzip.net-git
+_srcname=RVWorld
+pkgver=r17.7513f4e
+pkgrel=1
+pkgdesc='Torrentzip utility with mutli core processing capability (git version)'
+arch=('any')
+url='http://www.romvault.com/trrntzip/'
+license=('MIT')
+depends=('mono' 'sh' 'hicolor-icon-theme')
+makedepends=('git' 'imagemagick')
+provides=('torrentip.net')
+conflicts=('torrentip.net')
+source=('git+https://github.com/RomVault/RVWorld.git'
+ 'TrrntZip.NET'
+ 'TrrntZipUI'
+ 'torrentzip.net.desktop'
+ 'torrentzip.net-git-no-ilmerge.patch'
+ 'torrentzip.net-git-fix-case.patch'
+ 'torrentzip.net-git-linux-fix.patch')
+sha256sums=('SKIP'
+ 'fcec85063da4f78dc853f443493709458ae627aaf8968476c7ea02056b0982b0'
+ 'af32f3a2609a9eae37a2c836b0a4961230cfdffec6080d23fc94c5a0c4a181f0'
+ 'ab1f7bd79b7f255ee93b7986e3b8674eb32150c1043e349f351db2c29788aebe'
+ '6173068d16ca19f6b8e29cf176d0633a5b4a81b2986bd36a85e0fe5fa095a9f6'
+ '5f54911530550c5e4379422cbacea6258c7a0e07429b3530a12a6daad157585e'
+ '170fc46eb2af90ad47a76bbc3827219f024fe9b5df95b317202396ec299ae06d')
+
+prepare() {
+ cd "$_srcname"
+
+ # apply patches:
+ ## - do not statically link with ilmerge
+ ## - fix case to allow building on linux
+ ## - other linux fixes: more case fixes and .zip filename fix
+ for _patch in "${source[@]}"
+ do
+ [ "${_patch##*.}" != 'patch' ] && continue
+ printf '%s\n' " -> Applying patch '${_patch}'..."
+ patch -Np1 -i "${srcdir}/${_patch}"
+ done
+
+ # convert .ico to suitable formats
+ cd TrrntZipUI
+ magick convert memory-rom.ico torrentzip.net.png
+ magick convert memory-rom.ico torrentzip.net.svg
+}
+
+pkgver() {
+ cd "$_srcname"
+
+ # git, no tags available
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ printf '%s\n' ' -> Building TorrnetZip.NET CLI...'
+ cd "${_srcname}/TrrntZipCMD"
+ xbuild /p:Configuration='Release' TrrntZipCMD.csproj
+
+ printf '%s\n' ' -> Building TorrnetZip.NET GUI...'
+ cd "${srcdir}/${_srcname}/TrrntZipUI"
+ xbuild /p:Configuration='Release' TrrntZipUI.csproj
+}
+
+package() {
+ local _pkgbasename="${pkgname%-git}"
+
+ # launchers
+ install -D -m755 TrrntZip.NET -t "${pkgdir}/usr/bin"
+ install -D -m755 TrrntZipUI -t "${pkgdir}/usr/bin"
+ ln -s TrrntZip.NET "${pkgdir}/usr/bin/trrntzip.net"
+ ln -s TrrntZipUI "${pkgdir}/usr/bin/trrntzip.net-ui"
+
+ # binaries
+ cd "$_srcname"
+ install -D -m644 TrrntZipCMD/bin/Release/* -t "${pkgdir}/usr/lib/${_pkgbasename}"
+ install -D -m644 TrrntZipUI/bin/Release/TrrntZipUI.* -t "${pkgdir}/usr/lib/${_pkgbasename}"
+
+ # desktop file
+ install -D -m644 "${srcdir}/torrentzip.net.desktop" -t "${pkgdir}/usr/share/applications"
+
+ # icons
+ local _icon
+ local -a _icons
+ local _size
+ mapfile -t -d '' _icons < <(find TrrntZipUI -type f -name 'torrentzip.net*.png' -print0)
+ for _icon in "${_icons[@]}"
+ do
+ _size="$(magick identify -format '%[fx:w]' "$_icon")"
+ install -D -m644 "$_icon" "${pkgdir}/usr/share/icons/hicolor/${_size}x${_size}/apps/${_pkgbasename}.png"
+ done
+ install -D -m644 TrrntZipUI/torrentzip.net.svg -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+
+ # license
+ install -D -m644 "${srcdir}/${_srcname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
diff --git a/TrrntZip.NET b/TrrntZip.NET
new file mode 100644
index 000000000000..1700de646c08
--- /dev/null
+++ b/TrrntZip.NET
@@ -0,0 +1,3 @@
+#!/bin/sh
+export MONO_PATH="${MONO_PATH:+${MONO_PATH}:}/usr/lib/torrentzip.net"
+exec mono $MONO_OPTIONS /usr/lib/torrentzip.net/TrrntZip.NET.exe "$@"
diff --git a/TrrntZipUI b/TrrntZipUI
new file mode 100644
index 000000000000..b0cc271f9223
--- /dev/null
+++ b/TrrntZipUI
@@ -0,0 +1,3 @@
+#!/bin/sh
+export MONO_PATH="${MONO_PATH:+${MONO_PATH}:}/usr/lib/torrentzip.net"
+exec mono $MONO_OPTIONS /usr/lib/torrentzip.net/TrrntZipUI.exe "$@"
diff --git a/torrentzip.net-git-fix-case.patch b/torrentzip.net-git-fix-case.patch
new file mode 100644
index 000000000000..afb68e568ad6
--- /dev/null
+++ b/torrentzip.net-git-fix-case.patch
@@ -0,0 +1,12 @@
+diff -Nawurp a/TrrntZipUI/TrrntZipUI.csproj b/TrrntZipUI/TrrntZipUI.csproj
+--- a/TrrntZipUI/TrrntZipUI.csproj 2019-06-14 00:54:34.000000000 +0000
++++ b/TrrntZipUI/TrrntZipUI.csproj 2019-06-14 00:55:54.876336260 +0000
+@@ -83,7 +83,7 @@
+ <Compile Include="FrmTrrntzip.cs">
+ <SubType>Form</SubType>
+ </Compile>
+- <Compile Include="FrmTrrntzip.designer.cs">
++ <Compile Include="frmTrrntzip.designer.cs">
+ <DependentUpon>FrmTrrntzip.cs</DependentUpon>
+ </Compile>
+ <Compile Include="Program.cs" />
diff --git a/torrentzip.net-git-linux-fix.patch b/torrentzip.net-git-linux-fix.patch
new file mode 100644
index 000000000000..1107764012af
--- /dev/null
+++ b/torrentzip.net-git-linux-fix.patch
@@ -0,0 +1,40 @@
+diff -Nawurp a/Trrntzip/TorrentZipRebuild.cs b/Trrntzip/TorrentZipRebuild.cs
+--- a/Trrntzip/TorrentZipRebuild.cs 2019-06-14 01:54:19.000000000 +0000
++++ b/Trrntzip/TorrentZipRebuild.cs 2019-06-14 01:51:24.000000000 +0000
+@@ -36,10 +36,10 @@ namespace Trrntzip
+ int bufferSize = buffer.Length;
+
+ string filename = originalZipFile.ZipFilename;
+- string tmpFilename = Path.GetDirectoryName(filename) + Path.DirectorySeparatorChar + Path.GetFileNameWithoutExtension(filename) + ".tmp";
++ string tmpFilename = Path.Combine(Path.GetDirectoryName(filename),Path.GetFileNameWithoutExtension(filename) + ".tmp");
+
+ string outExt = outputType == zipType.zip ? ".zip" : ".7z";
+- string outfilename = Path.GetDirectoryName(filename) + Path.DirectorySeparatorChar + Path.GetFileNameWithoutExtension(filename) + outExt;
++ string outfilename = Path.Combine(Path.GetDirectoryName(filename), Path.GetFileNameWithoutExtension(filename) + outExt);
+
+ if (inputType != outputType)
+ {
+diff -Nawurp a/TrrntZipCMD/TrrntZipCMD.csproj b/TrrntZipCMD/TrrntZipCMD.csproj
+--- a/TrrntZipCMD/TrrntZipCMD.csproj 2019-06-14 01:54:19.000000000 +0000
++++ b/TrrntZipCMD/TrrntZipCMD.csproj 2019-06-14 01:51:24.000000000 +0000
+@@ -55,7 +55,7 @@
+ <Project>{ff8a7a0a-6319-49e0-a6e6-df3754bffdd1}</Project>
+ <Name>RVIO</Name>
+ </ProjectReference>
+- <ProjectReference Include="..\trrntzip\Trrntzip.csproj">
++ <ProjectReference Include="..\Trrntzip\Trrntzip.csproj">
+ <Project>{21822412-a4ce-4a55-bd41-aaea753753f1}</Project>
+ <Name>Trrntzip</Name>
+ </ProjectReference>
+diff -Nawurp a/TrrntZipUI/TrrntZipUI.csproj b/TrrntZipUI/TrrntZipUI.csproj
+--- a/TrrntZipUI/TrrntZipUI.csproj 2019-06-14 01:54:19.000000000 +0000
++++ b/TrrntZipUI/TrrntZipUI.csproj 2019-06-14 01:51:24.000000000 +0000
+@@ -123,7 +123,7 @@
+ <Project>{ff8a7a0a-6319-49e0-a6e6-df3754bffdd1}</Project>
+ <Name>RVIO</Name>
+ </ProjectReference>
+- <ProjectReference Include="..\trrntzip\Trrntzip.csproj">
++ <ProjectReference Include="..\Trrntzip\Trrntzip.csproj">
+ <Project>{21822412-a4ce-4a55-bd41-aaea753753f1}</Project>
+ <Name>Trrntzip</Name>
+ </ProjectReference>
diff --git a/torrentzip.net-git-no-ilmerge.patch b/torrentzip.net-git-no-ilmerge.patch
new file mode 100644
index 000000000000..0d986c6d4e39
--- /dev/null
+++ b/torrentzip.net-git-no-ilmerge.patch
@@ -0,0 +1,40 @@
+diff -Nawurp a/TrrntZipCMD/TrrntZipCMD.csproj b/TrrntZipCMD/TrrntZipCMD.csproj
+--- a/TrrntZipCMD/TrrntZipCMD.csproj 2019-06-14 01:03:24.000000000 +0000
++++ b/TrrntZipCMD/TrrntZipCMD.csproj 2019-06-14 01:06:21.588797155 +0000
+@@ -61,15 +61,4 @@
+ </ProjectReference>
+ </ItemGroup>
+ <Import Project="$(MSBuildToolsPath)\Microsoft.CSharp.targets" />
+- <Target Name="AfterBuild" Condition=" '$(Configuration)' == 'Release' ">
+- <CreateItem Include="@(ReferenceCopyLocalPaths)" Condition="'%(Extension)'=='.dll'">
+- <Output ItemName="AssembliesToMerge" TaskParameter="Include" />
+- </CreateItem>
+- <PropertyGroup>
+- <ReferenceAssemblies>C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.5</ReferenceAssemblies>
+- </PropertyGroup>
+- <Message Importance="high" Text="Executing ILMerge...with target platform from $(ReferenceAssemblies)" />
+- <Exec Command="&quot;C:\Program Files (x86)\Microsoft\ILMerge\ILMerge.exe&quot; /out:@(MainAssembly) /internalize /targetplatform:v4,&quot;$(ReferenceAssemblies)&quot; &quot;@(IntermediateAssembly)&quot; @(AssembliesToMerge->'&quot;%(FullPath)&quot;', ' ')" />
+- <Delete Files="@(ReferenceCopyLocalPaths->'$(OutDir)%(DestinationSubDirectory)%(Filename)%(Extension)')" />
+- </Target>
+ </Project>
+\ No newline at end of file
+diff -Nawurp a/TrrntZipUI/TrrntZipUI.csproj b/TrrntZipUI/TrrntZipUI.csproj
+--- a/TrrntZipUI/TrrntZipUI.csproj 2019-06-14 01:03:24.000000000 +0000
++++ b/TrrntZipUI/TrrntZipUI.csproj 2019-06-14 01:06:27.992184027 +0000
+@@ -149,15 +149,4 @@
+ <Target Name="BeforeBuild">
+ </Target>
+ -->
+- <Target Name="AfterBuild" Condition=" '$(Configuration)' == 'Release' ">
+- <CreateItem Include="@(ReferenceCopyLocalPaths)" Condition="'%(Extension)'=='.dll'">
+- <Output ItemName="AssembliesToMerge" TaskParameter="Include" />
+- </CreateItem>
+- <PropertyGroup>
+- <ReferenceAssemblies>C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.5</ReferenceAssemblies>
+- </PropertyGroup>
+- <Message Importance="high" Text="Executing ILMerge...with target platform from $(ReferenceAssemblies)" />
+- <Exec Command="&quot;C:\Program Files (x86)\Microsoft\ILMerge\ILMerge.exe&quot; /out:@(MainAssembly) /internalize /targetplatform:v4,&quot;$(ReferenceAssemblies)&quot; &quot;@(IntermediateAssembly)&quot; @(AssembliesToMerge->'&quot;%(FullPath)&quot;', ' ')" />
+- <Delete Files="@(ReferenceCopyLocalPaths->'$(OutDir)%(DestinationSubDirectory)%(Filename)%(Extension)')" />
+- </Target>
+ </Project>
+\ No newline at end of file
diff --git a/torrentzip.net.desktop b/torrentzip.net.desktop
new file mode 100644
index 000000000000..116a37292ecb
--- /dev/null
+++ b/torrentzip.net.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=TorrentZip.NET
+Comment=Torrentzip utility with mutli core processing capability
+Path=/usr/bin
+Exec=TrrntZipUI
+Icon=torrentzip.net.png
+Terminal=false
+StartupNotify=false
+Type=Application
+Categories=Application;Utilities;