summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD81
-rw-r--r--toxcore.conf2
-rw-r--r--toxcore.install11
4 files changed, 62 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a0de4b417d3..7dc851176f9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,30 @@
-# Generated by mksrcinfo v8
-# Tue Jul 5 01:17:08 UTC 2016
pkgbase = toxcore-git
- pkgdesc = Secure, configuration-free, P2P Skype replacement backend
- pkgver = r3758.532629d
+ pkgdesc = Peer to peer (serverless) instant messenger core
+ pkgver = 0.2.12.r26.ga71ddc7ea
pkgrel = 1
- url = https://tox.chat
- install = toxcore.install
+ url = https://tox.chat/
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- makedepends = check
- depends = systemd
+ makedepends = cmake
+ depends = glibc
depends = libconfig
depends = libsodium
depends = libvpx
depends = opus
- provides = tox
provides = toxcore
- conflicts = tox
+ provides = tox
conflicts = toxcore
+ conflicts = tox
+ options = staticlibs
backup = etc/tox-bootstrapd.conf
- source = git+https://github.com/irungentoo/toxcore.git
- source = toxcore.conf
- sha512sums = SKIP
- sha512sums = 71885e69f7b84955f6bdbf27b9e8196349cdd254b02b510433851bd218374d9c47aa7d3946dcc6a5cff6c8e705bc98d8a09de27039f60b8b088784cf8fa9d719
+ source = git+https://github.com/TokTok/c-toxcore.git
+ source = toxcore.conf::https://raw.githubusercontent.com/archlinux/svntogit-community/packages/toxcore/trunk/toxcore.conf
+ source = toxcore.tmpfiles::https://raw.githubusercontent.com/archlinux/svntogit-community/packages/toxcore/trunk/toxcore.tmpfiles
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = toxcore-git
diff --git a/PKGBUILD b/PKGBUILD
index 1dc4ca98c9c8..9e537b6651ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Ivan Shapovalov <intelfx@intelfx.name>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Previous maintainer: Ivan Shapovalov <intelfx@intelfx.name>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
# Contributor: naxuroqa <naxuroqa at gmail.com>
@@ -6,49 +7,63 @@
# Contributor: Kevin MacMartin <prurigro at gmail dot com>
pkgname=toxcore-git
-_pkgname=toxcore
-pkgver=r3758.532629d
+pkgver=0.2.12.r26.ga71ddc7ea
pkgrel=1
-pkgdesc='Secure, configuration-free, P2P Skype replacement backend'
+pkgdesc="Peer to peer (serverless) instant messenger core"
arch=('i686' 'x86_64')
-url='https://tox.chat'
+url="https://tox.chat/"
license=('GPL3')
-depends=('systemd' 'libconfig' 'libsodium' 'libvpx' 'opus')
-makedepends=('git' 'check')
-conflicts=("tox" "toxcore")
-provides=("tox" "toxcore")
+depends=('glibc' 'libconfig' 'libsodium' 'libvpx' 'opus')
+makedepends=('git' 'cmake')
+provides=('toxcore' 'tox')
+conflicts=('toxcore' 'tox')
backup=('etc/tox-bootstrapd.conf')
-install=$_pkgname.install
-source=("git+https://github.com/irungentoo/toxcore.git"
- 'toxcore.conf')
-sha512sums=('SKIP'
- '71885e69f7b84955f6bdbf27b9e8196349cdd254b02b510433851bd218374d9c47aa7d3946dcc6a5cff6c8e705bc98d8a09de27039f60b8b088784cf8fa9d719')
+options=('staticlibs')
+source=("git+https://github.com/TokTok/c-toxcore.git"
+ "toxcore.conf::https://raw.githubusercontent.com/archlinux/svntogit-community/packages/toxcore/trunk/toxcore.conf"
+ "toxcore.tmpfiles::https://raw.githubusercontent.com/archlinux/svntogit-community/packages/toxcore/trunk/toxcore.tmpfiles")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
-pkgver() {
- cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
prepare() {
- cd $_pkgname
- sed -i "s|/usr/local|/usr|" other/bootstrap_daemon/tox-bootstrapd.service
+ cd "c-toxcore"
+
+ sed -i "s|/usr/local|/usr|" "other/bootstrap_daemon/tox-bootstrapd.service"
+}
+
+pkgver() {
+ cd "c-toxcore"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $_pkgname
- autoreconf -if
- ./configure \
- --prefix=/usr \
- --enable-daemon \
- --disable-ntox \
- --enable-tests
- make
+ cd "c-toxcore"
+
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ ./
+ make -C "_build"
+}
+
+check() {
+ cd "c-toxcore"
+
+ make -C "_build" test
}
package() {
- cd $_pkgname
- make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/toxcore.conf" "$pkgdir/usr/lib/sysusers.d/toxcore.conf"
- install -Dm644 ./other/bootstrap_daemon/tox-bootstrapd.service "$pkgdir/usr/lib/systemd/system/tox-bootstrapd.service"
- install -Dm644 ./other/bootstrap_daemon/tox-bootstrapd.conf "$pkgdir/etc/tox-bootstrapd.conf"
+ cd "c-toxcore"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/toxcore.conf" -t "$pkgdir/usr/lib/sysusers.d"
+ install -Dm644 "$srcdir/toxcore.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/toxcore.conf"
+ install -Dm644 "other/bootstrap_daemon/tox-bootstrapd.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm644 "other/bootstrap_daemon/tox-bootstrapd.conf" -t "$pkgdir/etc"
}
diff --git a/toxcore.conf b/toxcore.conf
deleted file mode 100644
index 42d040fff0fb..000000000000
--- a/toxcore.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-u tox-bootstrapd - "Tox bootstrapd"
-g tox-bootstrapd - \ No newline at end of file
diff --git a/toxcore.install b/toxcore.install
deleted file mode 100644
index f2ccedabb8f0..000000000000
--- a/toxcore.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- systemd-sysusers toxcore.conf
- [[ -d var/lib/tox-bootstrapd ]] || install -dm 750 -o tox-bootstrapd -g tox-bootstrapd var/lib/tox-bootstrapd
-}
-
-post_upgrade() {
- (( $(vercmp $2 '3523-3') < 0 )) && (
- systemd-sysusers toxcore.conf
- [[ -d var/lib/tox-bootstrapd ]] || install -dm 750 -o tox-bootstrapd -g tox-bootstrapd var/lib/tox-bootstrapd
- ) || true
-}