summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD44
3 files changed, 34 insertions, 31 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 23fc972828aa..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,15 +0,0 @@
-pkgbase = tpasm
- pkgdesc = A cross assembler for 6805, 6809, 68HC11, 6502, Sunplus, 8051, Z80, PIC, AVR and c166
- pkgver = 1.8
- pkgrel = 2
- url = http://www.sqrt.com/
- arch = i686
- arch = x86_64
- license = GPL
- depends = gcc-libs
- source = http://www.sqrt.com/downloads/tpasm.tgz
- options = strip
- options = !emptydirs
-
-pkgname = tpasm
-
diff --git a/.SRCINFO b/.SRCINFO
index 54c16e97caa7..5224ed46d51b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tpasm
pkgdesc = A cross assembler for 6805, 6809, 68HC11, 6502, Sunplus, 8051, Z80, PIC, AVR and c166
- pkgver = 1.8
- pkgrel = 2
+ pkgver = 1.11
+ pkgrel = 1
url = http://www.sqrt.com/
arch = i686
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = tpasm
options = strip
options = !emptydirs
source = http://www.sqrt.com/downloads/tpasm.tgz
- md5sums = ce58fc2a66ba7712fab7318383ed8c91
+ md5sums = f7019e0453f9f25a461118652b81d294
pkgname = tpasm
diff --git a/PKGBUILD b/PKGBUILD
index 78cb513f393c..bb165783948d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,14 @@
-# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+#
+# PKGBUILD: tpasm
+#
+# Maintainer: uffe Jakobsen <_microtop_-at-_starion_-_dot_-_dk>
+#
+# Past Maintainer: Steven Honeyman <stevenhoneyman -at_ gmail -dot_ com>
+#
pkgname=tpasm
-pkgver=1.8
-pkgrel=2
+pkgver=1.11
+pkgrel=1
pkgdesc="A cross assembler for 6805, 6809, 68HC11, 6502, Sunplus, 8051, Z80, PIC, AVR and c166"
arch=('i686' 'x86_64')
url="http://www.sqrt.com/"
@@ -10,18 +16,30 @@ license=('GPL')
depends=(gcc-libs)
options=('strip' '!emptydirs')
source=(http://www.sqrt.com/downloads/tpasm.tgz)
-md5sums=('ce58fc2a66ba7712fab7318383ed8c91')
+md5sums=('f7019e0453f9f25a461118652b81d294')
-build() {
- cd "$srcdir/$pkgname$pkgver"
+#
+#
+#
+build()
+{
+ cd "${srcdir}/${pkgname}${pkgver}"
make
}
-package() {
- cd "$srcdir/$pkgname$pkgver"
- install -Dm 755 tpasm $pkgdir/usr/bin/tpasm
-
- mkdir -p $pkgdir/usr/share/doc/$pkgname-$pkgver/samples
- install -m 644 *.TXT $pkgdir/usr/share/doc/$pkgname-$pkgver
- install -m 644 samples/* $pkgdir/usr/share/doc/$pkgname-$pkgver/samples
+#
+#
+#
+package()
+{
+ cd "${srcdir}/${pkgname}${pkgver}"
+ install -Dm 755 tpasm "${pkgdir}/usr/bin/tpasm"
+
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/samples"
+ install -m 644 *.TXT "${pkgdir}/usr/share/doc/${pkgname}-${pkgver}"
+ install -m 644 samples/* "${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/samples"
}
+
+#
+# EOF
+#