summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
-rw-r--r--tractags.patch30
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fee46d34cbbe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 23 20:46:03 UTC 2015
+pkgbase = trac-tagsplugin
+ pkgdesc = A tagging system for Trac.
+ pkgver = 0.7
+ pkgrel = 2
+ url = http://trac-hacks.org/wiki/TagsPlugin
+ arch = any
+ license = custom
+ makedepends = subversion
+ makedepends = python2-setuptools
+ depends = trac>=1.0
+ source = svn+https://trac-hacks.org/svn/tagsplugin/tags/0.7#revision=13816
+ source = tractags.patch
+ md5sums = SKIP
+ md5sums = 8945d5608013c28198d9cfbbad2932d6
+
+pkgname = trac-tagsplugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ade0439e5b3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Oleg Plakhotniuk <olegus EIGHT AT gmail DOT com>
+pkgname=trac-tagsplugin
+pkgver=0.7
+pkgrel=2
+pkgdesc="A tagging system for Trac."
+arch=('any')
+url="http://trac-hacks.org/wiki/TagsPlugin"
+license=('custom')
+depends=('trac>=1.0')
+makedepends=('subversion' 'python2-setuptools')
+source=(svn+https://trac-hacks.org/svn/tagsplugin/tags/$pkgver#revision=13816
+ tractags.patch)
+md5sums=('SKIP'
+ '8945d5608013c28198d9cfbbad2932d6')
+
+prepare() {
+ cd "$srcdir/$pkgver"
+ patch -p0 < ../tractags.patch
+}
+
+package() {
+ cd "$srcdir/$pkgver"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
diff --git a/tractags.patch b/tractags.patch
new file mode 100644
index 000000000000..2f9feba0bc89
--- /dev/null
+++ b/tractags.patch
@@ -0,0 +1,30 @@
+Index: tractags/db.py
+===================================================================
+--- tractags/db.py (revision 13816)
++++ tractags/db.py (working copy)
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+ #
+ # Copyright (C) 2012 Steffen Hoffmann <hoff.st@web.de>
+Index: tractags/db_default.py
+===================================================================
+--- tractags/db_default.py (revision 13816)
++++ tractags/db_default.py (working copy)
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+ #
+ # Copyright (C) 2012,2013 Steffen Hoffmann <hoff.st@web.de>
+Index: tractags/model.py
+===================================================================
+--- tractags/model.py (revision 13816)
++++ tractags/model.py (working copy)
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+ #
+ # Copyright (C) 2014 Jun Omae <jun66j5@gmail.com>