summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d4aaecc8821
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tracking
+ pkgdesc = Analyze how the behavior of a parallel application evolves through different scenarios (from BSC).
+ pkgver = 2.6.10
+ pkgrel = 1
+ url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ depends = wxparaver
+ depends = clusteringsuite
+ depends = python-pillow
+ depends = python-wxpython
+ depends = python-matplotlib
+ source = https://ftp.tools.bsc.es/tracking/tracking-2.6.10-src.tar.bz2
+ sha512sums = 577783edf85f9a53fdabc8a25556fca806c8a9c3df28d713815fc5cccb63450bf3a5d0ee904bec4e7b125f3278d75e6c2b9c2e899f14ab4694d288b07db3eb9d
+
+pkgname = tracking
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef5bdc5d0768
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
+pkgname='tracking'
+pkgdesc='Analyze how the behavior of a parallel application evolves through different scenarios (from BSC).'
+pkgver='2.6.10'
+pkgrel='1'
+arch=('i686' 'x86_64')
+url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
+license=('GPLv2')
+depends=(wxparaver clusteringsuite python-pillow python-wxpython python-matplotlib)
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
+sha512sums=(577783edf85f9a53fdabc8a25556fca806c8a9c3df28d713815fc5cccb63450bf3a5d0ee904bec4e7b125f3278d75e6c2b9c2e899f14ab4694d288b07db3eb9d)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --with-paraver=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make prefix="$pkgdir/usr/" install # NB: using DESTDIR instead, does not work
+}