summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD11
-rw-r--r--tracks.install2
-rw-r--r--tracks.service2
5 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcdfe47dc358..b1fc072d817a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tracks
pkgdesc = Web-based application helping to implement the 'Getting things done' methodology
- pkgver = 2.2.3
+ pkgver = 2.3.0
pkgrel = 1
url = http://www.getontracks.org/
install = tracks.install
@@ -16,10 +16,10 @@ pkgbase = tracks
backup = usr/share/webapps/tracks/db/tracks.sqlite3.db
source = default_db.patch
source = tracks.service
- source = tracks.zip::https://github.com/TracksApp/tracks/zipball/v2.2.3
+ source = tracks.zip::https://github.com/TracksApp/tracks/zipball/v2.3.0
sha256sums = d6a762be317e3753d50aca29a953cd5c8ef0aae6ddabd5807124e2e41ba46f48
sha256sums = 31f09cd39b632c91dd47e92780d29e84e2173abe268f0286de14f6126e1ba018
- sha256sums = 3bd7eb466aefb65e7bea2ae05c64f0494be5df71555ff9711f74981b275f6472
+ sha256sums = f9e9524e89748f11e797a09f53ea201ec9438a62465fdfa3cfbc4e9cfbb86ce4
pkgname = tracks
diff --git a/.gitignore b/.gitignore
index 18eca42e1a06..c71cdd605bf4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,4 @@
+pkg/
+src/
tracks.zip
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 2a47bda6136e..8b43e8b2505a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Sebastian Schäfer <sarek@uliweb.de>
pkgname=tracks
-pkgver=2.2.3
+pkgver=2.3.0
pkgrel=1
pkgdesc="Web-based application helping to implement the 'Getting things done' methodology"
arch=('any')
@@ -20,7 +20,7 @@ source=(
install="${pkgname}.install"
sha256sums=('d6a762be317e3753d50aca29a953cd5c8ef0aae6ddabd5807124e2e41ba46f48'
'31f09cd39b632c91dd47e92780d29e84e2173abe268f0286de14f6126e1ba018'
- '3bd7eb466aefb65e7bea2ae05c64f0494be5df71555ff9711f74981b275f6472')
+ 'f9e9524e89748f11e797a09f53ea201ec9438a62465fdfa3cfbc4e9cfbb86ce4')
_tracks_archive_path='TracksApp-tracks-f98d32c'
prepare() {
@@ -35,9 +35,6 @@ prepare() {
# Patch database.yml to use the sqlite default database
patch -p0 < "${srcdir}/default_db.patch"
- # Add Mongrel to Gemfile
- sed -i "4igem 'mongrel', '>=1.2.0.pre2'\n" Gemfile
-
# Configure Tracks to serve static assets via Mongrel
sed -i \
's/config.serve_static_assets = false/config.serve_static_assets = true/' \
@@ -48,13 +45,13 @@ build() {
cd "${srcdir}/${_tracks_archive_path}"
# Use bundler to install required gems
- bundle install --without development,test --path .bundle
+ bundle install --without development test --path vendor/bundle
# Initialize the default sqlite Database
bundle exec rake db:migrate RAILS_ENV=production
# Precompile static assets
- bundle exec rake assets:precompile
+ bundle exec rake assets:precompile RAILS_ENV=production
}
package() {
diff --git a/tracks.install b/tracks.install
index 9864bfe25c6e..e6293725e2aa 100644
--- a/tracks.install
+++ b/tracks.install
@@ -8,7 +8,7 @@ database. Simply start the systemd unit and navigate to http://server:10008/
If you want to use your own webserver or a different database please consult
the Tracks installation documentation here:
- https://github.com/TracksApp/tracks/blob/v2.2.2/doc/installation.textile
+ https://github.com/TracksApp/tracks/blob/master/doc/installation.md
All tracks data is stored in /usr/share/webapps/tracks/ (where you'll need to
run the commands listed in the documentation)
diff --git a/tracks.service b/tracks.service
index 938879e07195..46c89fa77ec8 100644
--- a/tracks.service
+++ b/tracks.service
@@ -8,7 +8,7 @@ After=postgresql.service
[Service]
Type=simple
WorkingDirectory=/usr/share/webapps/tracks
-ExecStart=/usr/bin/bundle exec rails server mongrel -e production -p 10008
+ExecStart=/usr/bin/bundle exec rails server -e production -p 10008
User=http
Group=http
StandardOutput=syslog