summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD60
-rw-r--r--transabyss-profile.sh1
-rw-r--r--transabyss.install35
4 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0ab45ab9e82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = transabyss
+ pkgdesc = de novo assembly of RNA-Seq data using ABySS
+ pkgver = 1.5.3
+ pkgrel = 1
+ url = http://www.bcgsc.ca/platform/bioinfo/software/trans-abyss
+ install = transabyss.install
+ arch = any
+ license = custom
+ depends = abyss
+ depends = blat
+ depends = bowtie2
+ depends = gawk
+ depends = gmap-gsnap
+ depends = python2-biopython
+ depends = python2-igraph
+ depends = python2-pysam
+ depends = samtools
+ backup = etc/transabyss/job_script.cfg
+ backup = etc/transabyss/model_matcher.cfg
+ backup = etc/transabyss/transcriptome.cfg
+ source = transabyss-1.5.3.zip::https://github.com/bcgsc/transabyss/archive/1.5.3.zip
+ source = transabyss.install
+ source = transabyss-profile.sh
+ md5sums = 8323e601face2f5b65f2ff667ae5853e
+ md5sums = 9c5d33c3294e31dedada51553fa91dee
+ md5sums = 8367c572ac97d29bfee8b2920cfb957b
+
+pkgname = transabyss
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfe3d2be1b27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=transabyss
+pkgver=1.5.3
+pkgrel=1
+pkgdesc='de novo assembly of RNA-Seq data using ABySS'
+arch=('any')
+url="http://www.bcgsc.ca/platform/bioinfo/software/trans-abyss"
+license=('custom')
+depends=('abyss' 'blat' 'bowtie2' 'gawk' 'gmap-gsnap' 'python2-biopython' 'python2-igraph' 'python2-pysam' 'samtools')
+source=("$pkgname-$pkgver.zip::https://github.com/bcgsc/transabyss/archive/$pkgver.zip"
+ transabyss.install
+ transabyss-profile.sh)
+install=transabyss.install
+backup=('etc/transabyss/job_script.cfg'
+ 'etc/transabyss/model_matcher.cfg'
+ 'etc/transabyss/transcriptome.cfg')
+md5sums=('8323e601face2f5b65f2ff667ae5853e'
+ '9c5d33c3294e31dedada51553fa91dee'
+ '8367c572ac97d29bfee8b2920cfb957b')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
+ -e 's|#! /usr/bin/env python|#!/usr/bin/env python2|' \
+ -i transabyss* utilities/*.py
+
+ sed -e 's|python|python2|' \
+ -i analysis/fusion.py
+
+ sed -e 's|time python|time python2|' \
+ -i transabyss-analyze
+
+ rm -r prereqs
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ mkdir -p $pkgdir/usr/share/transabyss \
+ $pkgdir/usr/share/licenses/transabyss \
+ $pkgdir/usr/bin \
+ $pkgdir/etc/transabyss
+
+ cp -r * $pkgdir/usr/share/transabyss
+
+ for i in transabyss transabyss-analyze transabyss-merge ; do
+ ln -s /usr/share/transabyss/$i $pkgdir/usr/bin/$i
+ done
+
+ for i in configs/*.cfg ; do
+ cp $i $pkgdir/etc/transabyss/$(basename $i)
+ ln -sf /etc/transabyss/$(basename $i) $pkgdir/usr/share/transabyss/$i
+ done
+
+ install -Dm644 $srcdir/transabyss-profile.sh $pkgdir/etc/profile.d/transabyss.sh
+
+ ln -s /usr/share/transabyss/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/transabyss-profile.sh b/transabyss-profile.sh
new file mode 100644
index 000000000000..f41f8ac03fbd
--- /dev/null
+++ b/transabyss-profile.sh
@@ -0,0 +1 @@
+export PYTHONPATH="/usr/share/transabyss:$PYTHONPATH"
diff --git a/transabyss.install b/transabyss.install
new file mode 100644
index 000000000000..d65d553051b1
--- /dev/null
+++ b/transabyss.install
@@ -0,0 +1,35 @@
+post_install() { cat << EOF
+
+Configuration
+-------------
+
+Configuration files are saved in:
+
+ /etc/transabyss
+
+You will most likely want to edit the genomes section transcriptome.cfg to point
+to the location of your genomes.
+
+Preparing Genomes
+-----------------
+
+The genomes are usually created by downloading a reference genome,
+e.g. [hg19][1], and running gmap_build, see [gmap README][2]:
+
+ gmap_build -g -d hg19 -D /path/to/genomes chr22.fa.gz
+
+[1]: ftp://hgdownload.cse.ucsc.edu/goldenPath/hg19/chromosomes/
+[2]: http://research-pub.gene.com/gmap/src/README
+
+Getting Started
+---------------
+
+transabyss installs an /etc/profile.d/transabyss.sh script that you either need
+to source right now or restart your shell session.
+
+EOF
+}
+
+post_upgrade() {
+ post_install
+}