summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD50
2 files changed, 31 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38f566618c4f..acf536bac93a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = translate-shell-git
pkgdesc = A command-line interface and interactive shell for Google Translate.
- pkgver = v0.9.0.4.7.g1a4d83e
+ pkgver = 0.9.6.6.r3.g0060b10
pkgrel = 1
- url = http://www.soimort.org/translate-shell/
+ url = https://www.soimort.org/translate-shell/
arch = i686
arch = x86_64
license = custom:PublicDomain
makedepends = git
+ depends = gawk
+ depends = bash
optdepends = fribidi: display right-to-left languages
optdepends = mplayer: Text-to-Speech functionality
optdepends = mplayer2: Text-to-Speech functionality
@@ -16,7 +18,8 @@ pkgbase = translate-shell-git
optdepends = rlwrap: readline-style editing and history in the interactive mode
optdepends = emacs: Emacs interface
provides = translate-shell
- source = git://github.com/soimort/translate-shell.git
+ conflicts = translate-shell
+ source = git+https://github.com/soimort/translate-shell.git
md5sums = SKIP
pkgname = translate-shell-git
diff --git a/PKGBUILD b/PKGBUILD
index 5d121f8e8f78..6b4e735a5d38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,42 @@
-# Maintainer: Ivy Foster <joyfulgirl@archlinux.us>
+# Maintainer: Ivy Foster <code@escondida.tk>
# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
pkgname=translate-shell-git
-_gitname=translate-shell
-pkgver=v0.9.0.4.7.g1a4d83e
+pkgver=0.9.6.6.r3.g0060b10
pkgrel=1
pkgdesc='A command-line interface and interactive shell for Google Translate.'
-arch=('i686' 'x86_64')
-url="http://www.soimort.org/translate-shell/"
+arch=(i686 x86_64)
+url='https://www.soimort.org/translate-shell/'
license=('custom:PublicDomain')
-makedepends=('git')
+depends=(gawk bash)
+makedepends=(git)
optdepends=(
- 'fribidi: display right-to-left languages'
- 'mplayer: Text-to-Speech functionality'
- 'mplayer2: Text-to-Speech functionality'
- 'mpv: Text-to-Speech functionality'
- 'mpg123: Text-to-Speech functionality'
- 'espeak: Text-to-Speech functionality'
- 'rlwrap: readline-style editing and history in the interactive mode'
- 'emacs: Emacs interface'
+ 'fribidi: display right-to-left languages'
+ 'mplayer: Text-to-Speech functionality'
+ 'mplayer2: Text-to-Speech functionality'
+ 'mpv: Text-to-Speech functionality'
+ 'mpg123: Text-to-Speech functionality'
+ 'espeak: Text-to-Speech functionality'
+ 'rlwrap: readline-style editing and history in the interactive mode'
+ 'emacs: Emacs interface'
)
-provides=('translate-shell')
-source=("git://github.com/soimort/${_gitname}.git")
-md5sums=('SKIP')
+conflicts=(translate-shell)
+provides=(translate-shell)
+source=('git+https://github.com/soimort/translate-shell.git')
+md5sums=(SKIP)
pkgver() {
- cd $_gitname
- git describe --always | sed 's|-|.|g'
+ cd translate-shell
+ git describe | sed 's,^v,,; s@-\([0-9]\+\)-@.r\1.@'
}
build() {
- cd $_gitname
- make
+ cd translate-shell
+ make
}
package() {
- cd $_gitname
- install -d "${pkgdir}"/usr/{bin,share/man/man1}
- make PREFIX="${pkgdir}"/usr install
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${_gitname}/LICENSE
+ cd translate-shell
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/translate-shell-git/LICENSE"
}