summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD3
-rw-r--r--utp-debug.patch24
3 files changed, 30 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0d98cf182fa..6c3addc4c38c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jan 28 02:06:18 UTC 2018
+# Sun Jan 28 02:24:23 UTC 2018
pkgbase = transmission-i2p-git
pkgdesc = Standalone I2P BitTorrent Client over I2P network
pkgver = 2.82
@@ -15,10 +15,12 @@ pkgbase = transmission-i2p-git
conflicts = transmission-i2p
source = git+https://github.com/l-n-s/transmission-i2p.git
source = m4-glib-gettext.patch
+ source = utp-debug.patch
source = settings.json
source = transmission-i2p.service
md5sums = SKIP
md5sums = e8b2a730396b9e1e90acb4424d704063
+ md5sums = f554af5f5b1c200f1464122fad1c2272
md5sums = e801960cbf81ceb246108ca7edd8086f
md5sums = a5952b62a60d951948f9776aefa4715c
diff --git a/PKGBUILD b/PKGBUILD
index a662ec88c002..704cbda0c6c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,10 +15,12 @@ provides=(transmission-i2p)
conflicts=(transmission-i2p)
source=("git+https://github.com/l-n-s/transmission-i2p.git"
"m4-glib-gettext.patch"
+ "utp-debug.patch"
"settings.json"
"transmission-i2p.service")
md5sums=('SKIP'
'e8b2a730396b9e1e90acb4424d704063'
+ 'f554af5f5b1c200f1464122fad1c2272'
'e801960cbf81ceb246108ca7edd8086f'
'a5952b62a60d951948f9776aefa4715c')
install="transmission-i2p.install"
@@ -35,6 +37,7 @@ prepare() {
cd "$srcdir/$_gitname"
patch -p1 < ../m4-glib-gettext.patch
+ patch -p1 < ../utp-debug.patch
rm missing
diff --git a/utp-debug.patch b/utp-debug.patch
new file mode 100644
index 000000000000..aeb097648f1d
--- /dev/null
+++ b/utp-debug.patch
@@ -0,0 +1,24 @@
+diff --git a/third-party/libutp/utp.h b/third-party/libutp/utp.h
+index 0086d4c..b0f6e5b 100644
+--- a/third-party/libutp/utp.h
++++ b/third-party/libutp/utp.h
+@@ -130,17 +130,17 @@ void UTP_GetDelays(struct UTPSocket *socket, int32 *ours, int32 *theirs, uint32
+
+ size_t UTP_GetPacketSize(struct UTPSocket *socket);
+
+ #ifdef _DEBUG
+-struct UTPStats {
++typedef struct UTPStats {
+ uint64 _nbytes_recv; // total bytes received
+ uint64 _nbytes_xmit; // total bytes transmitted
+ uint32 _rexmit; // retransmit counter
+ uint32 _fastrexmit; // fast retransmit counter
+ uint32 _nxmit; // transmit counter
+ uint32 _nrecv; // receive counter (total)
+ uint32 _nduprecv; // duplicate receive counter
+-};
++} UTPStats;
+
+ // Get stats for UTP socket
+ void UTP_GetStats(struct UTPSocket *socket, UTPStats *stats);
+ #endif