summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-build-install-rebuilt-web-if-available.patch40
-rw-r--r--PKGBUILD13
3 files changed, 54 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cb3ddd1bea0..98c7afba61dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = transmission4
pkgver = 4.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.transmissionbt.com/
arch = x86_64
license = GPL
@@ -21,13 +21,15 @@ pkgbase = transmission4
makedepends = libnatpmp
makedepends = cmake
makedepends = ninja
- makedepends = yarn
+ makedepends = npm
source = https://github.com/transmission/transmission/releases/download/4.0.0/transmission-4.0.0.tar.xz
source = transmission-cli.sysusers
source = transmission-cli.tmpfiles
+ source = 0001-build-install-rebuilt-web-if-available.patch
sha256sums = af4f023c0b3f2417f62b314d84ea7f329ca080f86664f24b44246a8c50c6b10a
sha256sums = 641310fb0590d40e00bea1b5b9c843953ab78edf019109f276be9c6a7bdaf5b2
sha256sums = 1266032bb07e47d6bcdc7dabd74df2557cc466c33bf983a5881316a4cc098451
+ sha256sums = cefc852b5ab4d45a3f4df2073011cd28519655e300bbb29ac084cee3a21a6173
pkgname = transmission4-cli
pkgdesc = Fast, easy, and free BitTorrent client (CLI tools, daemon and web client) (version 4)
diff --git a/0001-build-install-rebuilt-web-if-available.patch b/0001-build-install-rebuilt-web-if-available.patch
new file mode 100644
index 000000000000..6981505b6e38
--- /dev/null
+++ b/0001-build-install-rebuilt-web-if-available.patch
@@ -0,0 +1,40 @@
+From d77619e0c45263831d6c69ef5b3832b5b09c6f0a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
+Date: Mon, 13 Feb 2023 15:08:52 +0000
+Subject: [PATCH] build: install rebuilt web if available
+
+---
+ CMakeLists.txt | 2 +-
+ web/CMakeLists.txt | 4 ++++
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ac2985510501..a54c493684a7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -772,7 +772,7 @@ foreach(P cli daemon gtk mac qt utils)
+ endif()
+ endforeach()
+
+-if(ENABLE_DAEMON OR ENABLE_GTK OR ENABLE_QT)
++if(NOT REBUILD_WEB AND (ENABLE_DAEMON OR ENABLE_GTK OR ENABLE_QT))
+ tr_install_web(${CMAKE_INSTALL_DATAROOTDIR}/${TR_NAME})
+ endif()
+
+diff --git a/web/CMakeLists.txt b/web/CMakeLists.txt
+index f26fc0f38f8b..4900348ddf05 100644
+--- a/web/CMakeLists.txt
++++ b/web/CMakeLists.txt
+@@ -87,3 +87,7 @@ add_custom_target("${TR_NAME}-web"
+ "${CMAKE_CURRENT_BINARY_DIR}/public_html/transmission-app.js.LICENSE.txt"
+ SOURCES
+ ${WEB_SOURCES})
++
++install(
++ DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/public_html
++ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/${TR_NAME})
+
+base-commit: a2faaabe693e051fb3b51ab24870a16273e7d940
+--
+2.39.1
+
diff --git a/PKGBUILD b/PKGBUILD
index e86e0619fb79..661fc407fce8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _pkgbase=transmission
pkgname=(transmission4-cli transmission4-gtk transmission4-qt libtransmission4)
pkgver=4.0.0
_pkgver=$pkgver
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="http://www.transmissionbt.com/"
license=(GPL)
@@ -29,15 +29,22 @@ makedepends=(
libnatpmp
cmake
ninja
- yarn
+ npm
)
source=(https://github.com/transmission/transmission/releases/download/${_pkgver%+*}/transmission-${_pkgver}.tar.xz
transmission-cli.sysusers
transmission-cli.tmpfiles
+ 0001-build-install-rebuilt-web-if-available.patch
)
sha256sums=('af4f023c0b3f2417f62b314d84ea7f329ca080f86664f24b44246a8c50c6b10a'
'641310fb0590d40e00bea1b5b9c843953ab78edf019109f276be9c6a7bdaf5b2'
- '1266032bb07e47d6bcdc7dabd74df2557cc466c33bf983a5881316a4cc098451')
+ '1266032bb07e47d6bcdc7dabd74df2557cc466c33bf983a5881316a4cc098451'
+ 'cefc852b5ab4d45a3f4df2073011cd28519655e300bbb29ac084cee3a21a6173')
+
+prepare() {
+ cd $_pkgbase-$_pkgver
+ patch -p1 < "$srcdir"/0001-build-install-rebuilt-web-if-available.patch
+}
build() {
cd $_pkgbase-$_pkgver