summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
-rw-r--r--treeline.desktop9
-rw-r--r--treeline.install12
-rw-r--r--treeline.xml7
5 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e35c3ee48e3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = treeline-unstable
+ pkgdesc = Tree outliner and PIM which stores any kind of information within a tree structure; unstable development snapshot
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://treeline.bellz.org
+ install = treeline.install
+ arch = any
+ license = GPL
+ depends = python-lxml
+ depends = python-pyqt4
+ depends = ispell
+ conflicts = treeline
+ replaces = treeline
+ source = http://sourceforge.net/projects/treeline/files/2.0.0/treeline-2.0.0.tar.gz/download
+ md5sums = 3f0a38b2c090dceacf89b7285cae99a6
+
+pkgname = treeline-unstable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bd3a85b9487
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ninian <mcfadzean.org.uk ta linux>
+
+pkgname=treeline-unstable
+_pkg=${pkgname%%-*}
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Tree outliner and PIM which stores any kind of information within a tree structure; unstable development snapshot"
+arch=(any)
+url="http://treeline.bellz.org"
+license=('GPL')
+depends=('python-lxml' 'python-pyqt4' 'ispell')
+conflicts=('treeline')
+replaces=('treeline')
+install=treeline.install
+source=("http://sourceforge.net/projects/treeline/files/${pkgver}/treeline-${pkgver}.tar.gz/download")
+md5sums=('3f0a38b2c090dceacf89b7285cae99a6')
+
+package() {
+ cd "$srcdir/TreeLine"
+ python install.py -p /usr -b "$pkgdir"
+ cd ../..
+ install -Dm644 $_pkg.desktop "$pkgdir/usr/share/applications/$_pkg.desktop"
+ install -Dm644 $_pkg.xml "$pkgdir/usr/share/mime/packages/x-$_pkg.xml"
+}
diff --git a/treeline.desktop b/treeline.desktop
new file mode 100644
index 000000000000..206298db53cd
--- /dev/null
+++ b/treeline.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Categories=Application;Office;Database;
+Name=TreeLine
+Comment=TreeLine outliner and database manager
+Icon=/usr/share/icons/treeline/tree/treelogo.png
+Terminal=false
+Exec=treeline %f
+MimeType=application/x-treeline;
diff --git a/treeline.install b/treeline.install
new file mode 100644
index 000000000000..4d8f62ad6dfe
--- /dev/null
+++ b/treeline.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-mime-database /usr/share/mime >/dev/null
+ update-desktop-database -q /usr/share/applications
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/treeline.xml b/treeline.xml
new file mode 100644
index 000000000000..fc1d8b90590c
--- /dev/null
+++ b/treeline.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-treeline">
+ <comment>TreeLine database</comment>
+ <glob pattern="*.trl"/>
+ </mime-type>
+</mime-info>