summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 28 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbbc75abfd1e..7655627edc45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = tribler
pkgdesc = Privacy enhanced BitTorrent client with P2P content discovery
pkgver = 7.1.0
pkgrel = 1
- url = http://www.tribler.org/
+ url = https://www.tribler.org/
arch = any
license = LGPL3
makedepends = python2-setuptools
@@ -37,6 +37,14 @@ pkgbase = tribler
conflicts = tribler
conflicts = python2-pyipv8
source = git+https://github.com/Tribler/tribler.git#tag=v7.1.0-exp3
+ source = git+https://github.com/Tribler/dispersy.git
+ source = git+https://github.com/devos50/pymdht.git
+ source = git+https://github.com/spesmilo/electrum
+ source = git+https://github.com/Tribler/py-ipv8.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = tribler
diff --git a/PKGBUILD b/PKGBUILD
index 6786c2e49cee..fa109e0b6f12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,33 @@ pkgver=7.1.0
_gitver=$pkgver-exp3
pkgrel=1
pkgdesc="Privacy enhanced BitTorrent client with P2P content discovery"
-url="http://www.tribler.org/"
-arch=(any)
+url="https://www.tribler.org/"
+arch=('any')
license=('LGPL3')
-depends=('python2-cryptography' 'python2-feedparser' 'python2-apsw' 'python2-cherrypy' 'python2-plyvel' 'python2-pillow' 'python2-pyqt5' 'qt5-svg' 'phonon-qt5-vlc' 'python2-feedparser' 'python2-chardet' 'python2-psutil' 'python2-meliae'
-'python2-decorator' 'python2-netifaces' 'python2-requests' 'python2-twisted' 'libsodium' 'libtorrent-rasterbar' 'python2-m2crypto' 'python2-configobj' 'python2-matplotlib' 'python2-service_identity' 'python2-keyring' 'python2-keyrings-alt')
+depends=('python2-cryptography' 'python2-feedparser' 'python2-apsw' 'python2-cherrypy' 'python2-plyvel'
+ 'python2-pillow' 'python2-pyqt5' 'qt5-svg' 'phonon-qt5-vlc' 'python2-feedparser' 'python2-chardet'
+ 'python2-psutil' 'python2-meliae' 'python2-decorator' 'python2-netifaces' 'python2-requests'
+ 'python2-twisted' 'libsodium' 'libtorrent-rasterbar' 'python2-m2crypto' 'python2-configobj'
+ 'python2-matplotlib' 'python2-service_identity' 'python2-keyring' 'python2-keyrings-alt')
optdepends=('vlc: for internal video player')
makedepends=('python2-setuptools')
provides=('tribler' 'python2-pyipv8')
conflicts=('tribler' 'python2-pyipv8')
-source=("git+https://github.com/Tribler/tribler.git#tag=v$_gitver")
-sha256sums=('SKIP')
+source=("git+https://github.com/Tribler/tribler.git#tag=v$_gitver"
+ 'git+https://github.com/Tribler/dispersy.git'
+ 'git+https://github.com/devos50/pymdht.git'
+ 'git+https://github.com/spesmilo/electrum'
+ 'git+https://github.com/Tribler/py-ipv8.git')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
prepare() {
cd "$srcdir"/$pkgname
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.Tribler/dispersy.url "$srcdir"/dispersy
+ git config submodule.Tribler/Core/DecentralizedTracking/pymdht.url "$srcdir"/pymdht
+ git config submodule.electrum.url "$srcdir"/electrum
+ git config submodule.py-ipv8.url "$srcdir"/py-ipv8
+ git submodule update
}
build () {