summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
-rw-r--r--trine3.desktop8
-rw-r--r--trine3.sh3
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4589fcf15e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = trine3-gog
+ pkgdesc = GOG version of Trine Enchanted Edition
+ pkgver = 2.2.0.4
+ pkgrel = 1
+ url = https://www.gog.com/game/trine_3_the_artifacts_of_power
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = xorg-xwininfo
+ depends = desktop-file-utils
+ depends = glu
+ depends = libxxf86vm
+ depends = openal
+ depends = libdrm
+ depends = libpng12
+ depends = libogg
+ depends = libvorbis
+ depends = freetype2
+ depends = libx11
+ source = gog_trine_3_the_artifacts_of_power_2.2.0.4.sh::gogdownloader://trine_3_the_artifacts_of_power/en3installer4
+ source = trine3.sh
+ source = trine3.desktop
+ sha256sums = 81e20187a3987d10b4472cfcdb0e14e2ff702b63ff2314597d894759dfe50968
+ sha256sums = 79b2e3a5a2837e0ac17a723e3204569279d068aee8eaac7d11805ddf9449302d
+ sha256sums = 9dc19a7b3f53637872b94588bcfb9b31c581d0a851b76dd9ddcd1b82610e3f69
+
+pkgname = trine3-gog
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..647e68abd563
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: John-Michael Mulesa <jmulesa at gmail dot com>
+
+pkgname=trine3-gog
+_pkgname=trine3
+pkgver=2.2.0.4
+pkgrel=1
+pkgdesc="GOG version of Trine Enchanted Edition"
+arch=("i686" "x86_64")
+url="https://www.gog.com/game/trine_3_the_artifacts_of_power"
+license=("custom")
+groups=("games")
+source=("gog_trine_3_the_artifacts_of_power_${pkgver}.sh::gogdownloader://trine_3_the_artifacts_of_power/en3installer4" "${_pkgname}.sh" "${_pkgname}.desktop")
+depends=('xorg-xwininfo' 'desktop-file-utils' 'glu' 'libxxf86vm' 'openal'
+ 'libdrm' 'libpng12' 'libogg' 'libvorbis' 'freetype2' 'libx11')
+sha256sums=('81e20187a3987d10b4472cfcdb0e14e2ff702b63ff2314597d894759dfe50968'
+ '79b2e3a5a2837e0ac17a723e3204569279d068aee8eaac7d11805ddf9449302d'
+ '9dc19a7b3f53637872b94588bcfb9b31c581d0a851b76dd9ddcd1b82610e3f69')
+
+# If you want to use lgogdownloader add the following to /etc/makepkg.conf
+# DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+DLAGENTS+=("gogdownloader::/usr/bin/echo Could not find gog installer file (%u). Manually download it to \"$(pwd)\", or set up a gogdownloader:// DLAGENT in /etc/makepkg.conf. See PKGBUILD for example.")
+
+package() {
+ # game files
+ mkdir -p "${pkgdir}/opt/${_pkgname}"
+ cp -r "${srcdir}/data/noarch/"* "${pkgdir}/opt/${_pkgname}/"
+
+ # launcher
+ chmod 755 "${pkgdir}/opt/${_pkgname}/start.sh"
+ install -Dm755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # desktop environment integration
+ install -Dm644 \
+ "${srcdir}/data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+ install -Dm644 \
+ "${srcdir}/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # license
+ install -Dm644 \
+ "${srcdir}/data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
diff --git a/trine3.desktop b/trine3.desktop
new file mode 100644
index 000000000000..92b0abd78bbb
--- /dev/null
+++ b/trine3.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Trine 3
+Comment=GOG version of Trine 3 The Artifacts of Power
+Exec=/usr/bin/trine3
+Icon=trine3
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/trine3.sh b/trine3.sh
new file mode 100644
index 000000000000..ad8580d1739d
--- /dev/null
+++ b/trine3.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/trine3
+./start.sh