summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
-rw-r--r--trueport-patch-6.8.0-6.8.3-stack-smashing.patch167
-rw-r--r--trueport-patch-signal_pending-kernel-4-11.patch16
4 files changed, 16 insertions, 203 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95783e7b6b95..33def3cb27e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jul 4 18:19:44 UTC 2018
+# Mon Feb 25 17:39:04 UTC 2019
pkgbase = trueport
pkgdesc = tty driver for Perle IOLan+ DS TS SDS STS SCS JetStream LanStream LinkStream and 3rd party serial console terminal device servers
- pkgver = 6.8.3_1
+ pkgver = 6.9.0_1
pkgrel = 1
url = https://www.perle.com/
install = trueport-install.sh
@@ -26,14 +26,10 @@ pkgbase = trueport
backup = etc/trueport/config.tp
backup = etc/trueport/pktfwdcfg.tp
backup = etc/trueport/sslcfg.tp
- source = https://www.perle.com/downloads/drivers/trueport/linux2.6/trueport-6.8.0-2.tgz
+ source = https://www.perle.com/downloads/drivers/trueport/linux2.6/trueport-6.9.0-1.tgz
source = tty_default_permissions.patch
- source = trueport-patch-6.8.0-6.8.3-stack-smashing.patch
- source = trueport-patch-signal_pending-kernel-4-11.patch
- sha256sums = c03dc972166fb693411cafcc7fb01478022dbc5da19d4db0f505591df819a72e
+ sha256sums = 299fd7781658f00a072dab48b188a856708b690381d6c1bb85a262222a07543c
sha256sums = 28863731fd99e447dc456312ef33e40f93623b56da0d345e45f40e238ca49639
- sha256sums = 12e94a054970784e8b75548f8a60eaa1372aeaf92adee911854db1163488c6ad
- sha256sums = 76157d41c665f36eddd4063aad05e75c53881b14d6a4218982da14b6aac9836e
pkgname = trueport
diff --git a/PKGBUILD b/PKGBUILD
index 5a7503233d9a..c6a2bb1dd36d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -93,9 +93,9 @@ _opt_masterttypfx='px' # default px (this isn't very useful to users)
set -u
pkgname='trueport'
-pkgver='6.8.3_1'
-#_dlver="${pkgver//_/-}"
-_dlver='6.8.0-2' # only use this with a version change patch set
+pkgver='6.9.0_1'
+_dlver="${pkgver//_/-}"
+#_dlver='6.8.0-2' # only use this with a version change patch set
_srcdir="${pkgname}-${_dlver%%-*}"
pkgrel='1'
pkgdesc='tty driver for Perle IOLan+ DS TS SDS STS SCS JetStream LanStream LinkStream and 3rd party serial console terminal device servers'
@@ -111,21 +111,19 @@ makedepends=('awk' 'sed' 'diffutils' 'patch')
backup=(etc/trueport/{config.tp,pktfwdcfg.tp,sslcfg.tp})
options=('!docs' '!emptydirs' '!strip')
install="${pkgname}-install.sh"
-_verwatch=('https://www.perle.com/downloads/server_ds1.shtml' '\s\+<a.*trueport-linux-tgz">\([^<]\+\)<.*' 'f')
+_verwatch=('https://www.perle.com/downloads/server_ds_ts.shtml' '\s\+<a.*trueport-linux-tgz">\([^<]\+\)<.*' 'f')
source=(
"https://www.perle.com/downloads/drivers/trueport/linux2.6/${pkgname}-${_dlver}.tgz"
'tty_default_permissions.patch'
- 'trueport-patch-6.8.0-6.8.3-stack-smashing.patch'
+ #'trueport-patch-6.8.0-6.8.5.patch'
# http://dpdk.org/dev/patchwork/patch/22003/ [dpdk-dev] kni: fix build with kernel 4.11 lib/librte_eal/linuxapp/kni/compat.h lib/librte_eal/linuxapp/kni/kni_dev.h
# http://dpdk.org/dev/patchwork/patch/22037/
# http://rglinuxtech.com/?p=1930
# https://forum.manjaro.org/t/error-with-rtl8812au/24066
- 'trueport-patch-signal_pending-kernel-4-11.patch'
+ #'trueport-patch-signal_pending-kernel-4-11.patch'
)
-sha256sums=('c03dc972166fb693411cafcc7fb01478022dbc5da19d4db0f505591df819a72e'
- '28863731fd99e447dc456312ef33e40f93623b56da0d345e45f40e238ca49639'
- '12e94a054970784e8b75548f8a60eaa1372aeaf92adee911854db1163488c6ad'
- '76157d41c665f36eddd4063aad05e75c53881b14d6a4218982da14b6aac9836e')
+sha256sums=('299fd7781658f00a072dab48b188a856708b690381d6c1bb85a262222a07543c'
+ '28863731fd99e447dc456312ef33e40f93623b56da0d345e45f40e238ca49639')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -138,9 +136,11 @@ prepare() {
cd "${_srcdir}"
# diff -pNaru5 'trueport-6.8.0' 'trueport-6.8.3' > 'trueport-patch-6.8.0-6.8.3-stack-smashing.patch'
- patch -Nup1 < '../trueport-patch-6.8.0-6.8.3-stack-smashing.patch'
+ #patch -Nup1 < '../trueport-patch-6.8.0-6.8.3-stack-smashing.patch'
# diff -pNau5 ptyx/ptys.c{.orig,} > '../trueport-patch-signal_pending-kernel-4-11.patch'
- patch -Nup0 < '../trueport-patch-signal_pending-kernel-4-11.patch'
+ #patch -Nup0 < '../trueport-patch-signal_pending-kernel-4-11.patch'
+ # diff -pNaru5 'trueport-6.8.0' 'trueport-6.8.5' > 'trueport-patch-6.8.0-6.8.5.patch'
+ #patch -Nup1 -i '../trueport-patch-6.8.0-6.8.5.patch'
# insert parameters and make install script non interactive.
sed -e 's:^\(DONE\)=.*$:'"\1='done';SSL='${_opt_SSL}':g" \
diff --git a/trueport-patch-6.8.0-6.8.3-stack-smashing.patch b/trueport-patch-6.8.0-6.8.3-stack-smashing.patch
deleted file mode 100644
index 866d7e862e4d..000000000000
--- a/trueport-patch-6.8.0-6.8.3-stack-smashing.patch
+++ /dev/null
@@ -1,167 +0,0 @@
-diff -pNaru5 trueport-6.8.0/pkt_forwarding.c trueport-6.8.3/pkt_forwarding.c
---- trueport-6.8.0/pkt_forwarding.c 2016-11-03 08:53:58.000000000 -0400
-+++ trueport-6.8.3/pkt_forwarding.c 2017-05-10 15:19:10.000000000 -0400
-@@ -628,12 +628,12 @@ void forward_frame( forwarding_info_t *
- if (UseNewPktFwdLogic(pInfo) )
- {
- // if theres a current data length then setup data pkt count
- if ( (pInfo->pCurrDataPkt != NULL) && pInfo->curr_data_count)
- {
-- *pInfo->pCurrDataPkt = (unsigned char)(((htons((uint16_t)pInfo->curr_data_count))>> 8) & 0xFF);
-- *(pInfo->pCurrDataPkt+1) = (unsigned char)((htons((uint16_t)pInfo->curr_data_count)) & 0xFF);
-+ *pInfo->pCurrDataPkt = (unsigned char)((((uint16_t)pInfo->curr_data_count)>> 8) & 0xFF);
-+ *(pInfo->pCurrDataPkt+1) = (unsigned char)(((uint16_t)pInfo->curr_data_count) & 0xFF);
- }
- else // if no current data then strip of pkt header
- {
- pInfo->count -= TPPKT_HDR_SIZE;
- }
-diff -pNaru5 trueport-6.8.0/pkt_forwarding.h trueport-6.8.3/pkt_forwarding.h
---- trueport-6.8.0/pkt_forwarding.h 2016-11-03 08:53:58.000000000 -0400
-+++ trueport-6.8.3/pkt_forwarding.h 2017-05-10 15:19:10.000000000 -0400
-@@ -93,12 +93,12 @@ typedef struct forwarding_info {
- unsigned char dscmd; // indicate in-line commands that need to put in pkt fwd buffer
-
- // forwarding buffer
- unsigned char *char_buf_ptr;
- int count;
-- unsigned long data_count; // count of only the data
-- unsigned long curr_data_count; // current data pkt data count when using new pkt fwd logic
-+ unsigned short data_count; // count of only the data
-+ unsigned short curr_data_count; // current data pkt data count when using new pkt fwd logic
- unsigned char *pCurrDataPkt; // this a pointer to the current data pkt
- unsigned char char_buf[MAX_PKT_FWD_BUF_SIZE];
- int write_blocked;
- } forwarding_info_t;
-
-diff -pNaru5 trueport-6.8.0/ptyx/ptym.c trueport-6.8.3/ptyx/ptym.c
---- trueport-6.8.0/ptyx/ptym.c 2016-11-03 08:53:58.000000000 -0400
-+++ trueport-6.8.3/ptyx/ptym.c 2017-05-10 15:19:10.000000000 -0400
-@@ -392,11 +392,15 @@ static int ptyx_master_ioctl(struct tty_
- ptyx_print(PTYX_DEBUG_IOCTL, ("ptyx_master_ioctl(%d): TCGETS, SLAVE NOT OPEN, returning default termios\n", ptyx_info->line));
- // slave not open so use the slave's default termios
- tmp_termios = &ptyx_info->s_driver->init_termios;
- }
- #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,23)) // Greater than 2.6.23
-- if (kernel_termios_to_user_termios((struct termios2 *)arg, tmp_termios))
-+#ifdef TCGETS2
-+ if (kernel_termios_to_user_termios_1((struct termios *)arg, tmp_termios))
-+#else
-+ if (kernel_termios_to_user_termios((struct termios *)arg, tmp_termios))
-+#endif
- #else
- if (kernel_termios_to_user_termios((struct termios *)arg, tmp_termios))
- #endif
- {
- ptyx_print(PTYX_DEBUG_IOCTL, ("ptyx_master_ioctl(%d): return -EFAULT\n", ptyx_info->line));
-diff -pNaru5 trueport-6.8.0/README trueport-6.8.3/README
---- trueport-6.8.0/README 2016-11-03 08:53:58.000000000 -0400
-+++ trueport-6.8.3/README 2017-05-10 15:19:10.000000000 -0400
-@@ -1,12 +1,12 @@
- ============================================================================
- Perle TruePort Daemon and Driver for Linux
-- Copyright (C) 2004-2016, Perle Systems Limited
-+ Copyright (C) 2004-2017, Perle Systems Limited
- =============================================================================
-
-- Release : 6.8.0
-- Date : September 2016
-+ Release : 6.8.3
-+ Date : May 2017
- O/S Compatibility : Linux Versions 2.6.x, 3.x, 4.x
-
- =============================================================================
-
- Introduction:
-@@ -134,10 +134,13 @@ Known Issues:
- Release History:
- ================
-
- Version Description
- ------- -----------
-+6.8.3 * Fix stack corruption issue in trueportd
-+6.8.2 * Fix issue with packet idle timeout forwarding option not working
-+6.8.1 * Fix issue with keep alive not working correctly
- 6.8.0 * Maintenance release
- * fixed issue with stty settings not being sent to the IOLAN
- 6.7.10 * Fix to work with 4.6.x kernels
- 6.7.9 * Fix for tty lockup while waiting for the TCP connection
- during an open.
-diff -pNaru5 trueport-6.8.0/tp.h trueport-6.8.3/tp.h
---- trueport-6.8.0/tp.h 2016-11-03 08:53:58.000000000 -0400
-+++ trueport-6.8.3/tp.h 2017-05-10 15:19:10.000000000 -0400
-@@ -1,18 +1,18 @@
- /******************************************************************
- Module: tp.h
-
- Description: Device Server Protocol Definitions for TruePort
-
-- Copyright (c) 1999-2015 Perle Systems Limited. All rights reserved.
-+ Copyright (c) 1999-2017 Perle Systems Limited. All rights reserved.
-
- *******************************************************************/
-
- #ifndef _TP_H
- #define _TP_H
-
--#define TP_VERSION "6.8.0"
-+#define TP_VERSION "6.8.3"
-
- #if defined(CONFIG_PPC64) || defined(CONFIG_SPARC64)
- #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,21))
- #include <linux/soundcard.h>
- #define TP_USE_SOUNDCARD_IOCTLS
-diff -pNaru5 trueport-6.8.0/trueportd.c trueport-6.8.3/trueportd.c
---- trueport-6.8.0/trueportd.c 2016-11-03 08:53:58.000000000 -0400
-+++ trueport-6.8.3/trueportd.c 2017-05-10 15:19:10.000000000 -0400
-@@ -452,11 +452,11 @@ int main(int argc, char **argv)
- trace(tl_error, "TCP port not specified\n");
- exit(-1);
- }
-
- trace(tl_status, "TruePort starting Version %s on port %d", TP_VERSION, tcp_port);
-- trace(tl_status, " - (c) 1999-2010, Perle Systems Limited\n" );
-+ trace(tl_status, " - (c) 1999-2017, Perle Systems Limited\n" );
-
- // if client I/O type name defined then set enumeration value
- if (io_type_name)
- {
- if (!strcmp(io_type_name, IOMBASCIIarg))
-@@ -814,14 +814,18 @@ int main(int argc, char **argv)
- // only do keep alive logic if in data transfer state
- if ( IsNoUDP() && (state == s_data_transfer) )
- {
- // if we've already sent one without a response then close connection
- // we will ignore keep-alive expiring if we are blocked on tty writes
-- if (keepalive_sent && !tty_write_blocked)
-+//debug-gps if (keepalive_sent && !tty_write_blocked)
-+ if (keepalive_sent)
- {
-- trace(tl_info, "No keep-alive response, Closing connection\n");
-- close_connection();
-+ if (!tty_write_blocked) //debug-gps
-+ {
-+ trace(tl_info, "No keep-alive response, Closing connection\n");
-+ close_connection();
-+ }
- keepalive_sent = 0;
- }
- else
- {
- ret = write_dserver_imm_ctrl(dserver_fd, DS_UDP_KEEP_ALIVE, 0);
-@@ -830,11 +834,14 @@ int main(int argc, char **argv)
- trace(tl_error, "Error sending Keep-alive immediate cmd, closing connection\n");
- close_connection();
- }
- else
- {
-- keepalive_sent = 1;
-+ if (!tty_write_blocked) //debug-gps
-+ {
-+ keepalive_sent = 1;
-+ }
- }
- }
- }
- // otherwise send UDP keep-alive
- // only do keep alive logic if in data transfer satae
diff --git a/trueport-patch-signal_pending-kernel-4-11.patch b/trueport-patch-signal_pending-kernel-4-11.patch
deleted file mode 100644
index ecd868b51806..000000000000
--- a/trueport-patch-signal_pending-kernel-4-11.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- ptyx/ptys.c.orig 2016-11-03 08:53:58.000000000 -0400
-+++ ptyx/ptys.c 2017-07-03 23:18:20.533207642 -0400
-@@ -24,10 +24,13 @@
-
- #include <linux/module.h> /* For EXPORT_SYMBOL */
-
- #include <linux/errno.h>
- #include <linux/sched.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+#include <linux/sched/signal.h>
-+#endif
- #include <linux/interrupt.h>
- #include <linux/tty.h>
- #include <linux/tty_flip.h>
- #include <linux/fcntl.h>
- #include <linux/string.h>