summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e346f82ba5fb..271b8644b27d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = trunk-recorder-git
pkgdesc = Records calls from a Trunked Radio System (P25 & SmartNet)
- pkgver = r1546.bd4975d
+ pkgver = r1612.ba6959f
pkgrel = 1
url = https://github.com/robotastic/trunk-recorder
arch = x86_64
@@ -12,14 +12,17 @@ pkgbase = trunk-recorder-git
license = GPL3
makedepends = git
makedepends = cmake
- makedepends = boost
+ makedepends = cppunit
depends = gnuradio
depends = gnuradio-osmosdr
depends = libuhd
+ depends = boost
depends = boost-libs
depends = sox
depends = fdkaac
- source = trunk-recorder-git::git+https://github.com/robotastic/trunk-recorder.git#branch=4.0-beta
+ options = debug
+ options = !strip
+ source = trunk-recorder-git::git+https://github.com/robotastic/trunk-recorder.git
source = trunk-recorder.service
source = trunk-recorder.sysusers
source = trunk-recorder.tmpfiles
diff --git a/PKGBUILD b/PKGBUILD
index c749b70be172..34a0ac6614a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Todd E Johnson <todd@toddejohnson.net>
+options=(debug !strip)
pkgname=trunk-recorder-git
-pkgver=r1546.bd4975d
+pkgver=r1612.ba6959f
pkgrel=1
pkgdesc="Records calls from a Trunked Radio System (P25 & SmartNet)"
arch=(x86_64 i686 armv5 armv6h armv7h aarch64)
url="https://github.com/robotastic/trunk-recorder"
license=("GPL3")
-depends=("gnuradio" "gnuradio-osmosdr" "libuhd" "boost-libs" "sox" "fdkaac")
-makedepends=("git" "cmake" "boost")
+depends=("gnuradio" "gnuradio-osmosdr" "libuhd" "boost" "boost-libs" "sox" "fdkaac")
+makedepends=("git" "cmake" "cppunit")
optdepends=()
-source=(${pkgname}::git+"https://github.com/robotastic/trunk-recorder.git#branch=4.0-beta"
+source=(${pkgname}::git+"https://github.com/robotastic/trunk-recorder.git"
'trunk-recorder.service'
'trunk-recorder.sysusers'
'trunk-recorder.tmpfiles')
@@ -28,9 +29,11 @@ prepare() {
mkdir build
}
build() {
+ CFLAGS=${CFLAGS/-fvar-tracking-assignments}
+ CXXFLAGS=${CXXFLAGS/-fvar-tracking-assignments}
cd build
cmake "../${pkgname}" \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=Debug \
-DCMAKE_INSTALL_PREFIX=/usr
make -j $(nproc)
}