summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 271b8644b27d..7c3eed5e120f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = trunk-recorder-git
pkgdesc = Records calls from a Trunked Radio System (P25 & SmartNet)
- pkgver = r1612.ba6959f
+ pkgver = r1621.ca33f8d
pkgrel = 1
url = https://github.com/robotastic/trunk-recorder
arch = x86_64
@@ -20,8 +20,9 @@ pkgbase = trunk-recorder-git
depends = boost-libs
depends = sox
depends = fdkaac
- options = debug
options = !strip
+ options = !buildflags
+ options = debug
source = trunk-recorder-git::git+https://github.com/robotastic/trunk-recorder.git
source = trunk-recorder.service
source = trunk-recorder.sysusers
diff --git a/PKGBUILD b/PKGBUILD
index 72e23a23a3d1..77f1200011d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Todd E Johnson <todd@toddejohnson.net>
-options=(debug !strip libtool staticlibs !ccache !distcc !zipman docs emptydirs)
+options=(!strip !buildflags debug )
pkgname=trunk-recorder-git
-pkgver=r1619.30f26ab
+pkgver=r1621.ca33f8d
pkgrel=1
pkgdesc="Records calls from a Trunked Radio System (P25 & SmartNet)"
arch=(x86_64 i686 armv5 armv6h armv7h aarch64)
@@ -29,11 +29,8 @@ prepare() {
mkdir build
}
build() {
- CFLAGS=${CFLAGS/-fvar-tracking-assignments}
- CXXFLAGS=${CXXFLAGS/-fvar-tracking-assignments}
cd build
cmake "../${pkgname}" \
- -DCMAKE_BUILD_TYPE=Debug \
-DCMAKE_INSTALL_PREFIX=/usr
make -j $(nproc)
}