summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD18
3 files changed, 36 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 577fa4a43dd9..1965886a0f03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = tshm-bin
pkgdesc = Parser and formatter for TypeScript declarations that outputs HM-style type signatures
- pkgver = 0.4.0
+ pkgver = 0.4.2
pkgrel = 1
- url = https://github.com/samhh/tshm/
+ url = https://github.com/samhh/tshm
arch = x86_64
license = MIT
- source = https://github.com/samhh/tshm//releases/download/0.4.0/tshm-linux-amd64
- source = https://github.com/samhh/tshm//archive/0.4.0.tar.gz
- sha256sums = ae8b310915be27b697cd64a2601b716007081b12d9538657c455d84a6f85d60e
- sha256sums = a40b8e8babfa7a70cdd290f2049c15ee687c3627188b0d1b79aa24f8758d4a8d
+ source = https://github.com/samhh/tshm/releases/download/0.4.2/tshm-0.4.2-linux-x86_64
+ source = LICENSE
+ sha256sums = 733041552fcdfc09e47f2897690f88edc194a8cd76e21ec7b79ac53c93008c2d
+ sha256sums = 3440871ff80806ee4369048b13f1557aa609ca9f655040c44a219d4b844425ba
pkgname = tshm-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..fed92726710d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+MIT License
+
+Copyright (c) 2020 Sam Ashley Horvath-Hunt
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
index 38c3c6be8d5c..26c30f0bc416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: Sam A. Horvath-Hunt <hello@samhh.com>
pkgname=tshm-bin
-pkgver=0.4.0
+pkgver=0.4.2
pkgrel=1
pkgdesc="Parser and formatter for TypeScript declarations that outputs HM-style type signatures"
-url="https://github.com/samhh/tshm/"
+url="https://github.com/samhh/tshm"
arch=("x86_64")
license=("MIT")
source=(
- "$url/releases/download/$pkgver/tshm-linux-amd64"
- "$url/archive/$pkgver.tar.gz"
-)
-sha256sums=(
- "ae8b310915be27b697cd64a2601b716007081b12d9538657c455d84a6f85d60e"
- "a40b8e8babfa7a70cdd290f2049c15ee687c3627188b0d1b79aa24f8758d4a8d"
+ "$url/releases/download/$pkgver/tshm-$pkgver-linux-x86_64"
+ "LICENSE"
)
+sha256sums=('733041552fcdfc09e47f2897690f88edc194a8cd76e21ec7b79ac53c93008c2d'
+ '3440871ff80806ee4369048b13f1557aa609ca9f655040c44a219d4b844425ba')
package() {
- install -Dm755 "tshm-linux-amd64" "$pkgdir/usr/bin/tshm"
- install -Dm644 "$srcdir/tshm-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/tshm/LICENSE"
+ install -Dm755 "tshm-$pkgver-linux-x86_64" "$pkgdir/usr/bin/tshm"
+ install -Dm644 "./LICENSE" "$pkgdir/usr/share/licenses/tshm/LICENSE"
}