summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE2
-rw-r--r--PKGBUILD27
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e68c7c3e7d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttcp
+ pkgdesc = TCP benchmarking tool
+ pkgver = 20100419
+ pkgrel = 1
+ url = http://www.pcausa.com/Utilities/pcattcp.htm
+ arch = i686
+ arch = x86_64
+ license = custom:Public Domain
+ depends = glibc
+ source = http://www.pcausa.com/Utilities/pcattcp/LinuxTTCP.zip
+ source = LICENSE
+ md5sums = 5b4707910c24fec212609f862bc53749
+ md5sums = d8d09df3d799fec1b0b8a080948ffbb2
+
+pkgname = ttcp
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0f47a56688ca
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,2 @@
+Distribution Status -
+ Public Domain. Distribution Unlimited.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..972f16a11670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=ttcp
+pkgver=20100419
+pkgrel=1
+pkgdesc="TCP benchmarking tool"
+arch=('i686' 'x86_64')
+url="http://www.pcausa.com/Utilities/pcattcp.htm"
+license=('custom:Public Domain')
+depends=('glibc')
+source=("http://www.pcausa.com/Utilities/pcattcp/LinuxTTCP.zip"
+ "LICENSE")
+md5sums=('5b4707910c24fec212609f862bc53749'
+ 'd8d09df3d799fec1b0b8a080948ffbb2')
+
+build() {
+ cd "${srcdir}/LinuxTTCP"
+ [ -f makefile ] && rm -f makefile
+ make ttcp
+}
+
+package() {
+ cd "$srcdir/LinuxTTCP"
+ install -D -m755 ttcp "${pkgdir}/usr/bin/ttcp"
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/ttcp/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: