summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--license2
-rw-r--r--ttf-ancient-fonts.install15
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c205cfccdc06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-ancient-fonts
+ pkgdesc = Unicode Fonts for Ancient Scripts
+ pkgver = 2.57
+ pkgrel = 1
+ url = http://users.teilar.gr/~g1951d/
+ install = ttf-ancient-fonts.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/ttf-ancient-fonts_2.57.orig.tar.gz
+ source = license
+ md5sums = ee28043d8454f31c6bffc84e55acd823
+ md5sums = 91258f5635a1c122f522a1330cd61bbf
+
+pkgname = ttf-ancient-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ce0e85df65d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alex Zose <alexander.zosimidis[at]gmail[dot]com>
+
+pkgname=ttf-ancient-fonts
+pkgver=2.57
+pkgrel=1
+pkgdesc="Unicode Fonts for Ancient Scripts"
+url="http://users.teilar.gr/~g1951d/"
+license=("custom")
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}.orig.tar.gz"
+ "license")
+md5sums=("ee28043d8454f31c6bffc84e55acd823"
+ "91258f5635a1c122f522a1330cd61bbf")
+install=$pkgname.install
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -d "$pkgdir/usr/share/licenses/${pkgname}"
+ install -m644 "$srcdir/${pkgname}-${pkgver}.orig/"*.ttf "$pkgdir/usr/share/fonts/TTF/"
+ install -m644 "license" "$pkgdir/usr/share/licenses/${pkgname}/license"
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..97dd9c07b301
--- /dev/null
+++ b/license
@@ -0,0 +1,2 @@
+These fonts are offered free for any use;
+they may be installed, embedded, opened, edited, modified, regenerated, posted, packaged and redistributed.
diff --git a/ttf-ancient-fonts.install b/ttf-ancient-fonts.install
new file mode 100644
index 000000000000..8e6e7346c45d
--- /dev/null
+++ b/ttf-ancient-fonts.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}