summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--LICENSE18
-rw-r--r--PKGBUILD22
-rw-r--r--ttf.install15
5 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3e753e79dea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-atarismall
+ pkgdesc = A very small 4x8 font, originally desinged for the Atari 800 terminal emulator
+ pkgver = 2.1
+ pkgrel = 1
+ url = http://gnu.ethz.ch/linuks.mine.nu/atari/
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://gnu.ethz.ch/linuks.mine.nu/atari/AtariSmall.ttf
+ source = LICENSE
+ md5sums = c6438c0c44cd78dd94d81fe19501981d
+ md5sums = d2d5d458e30a7143ec17383fee8f3b44
+
+pkgname = ttf-atarismall
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62d30f9218cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+src/
+pkg/
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c24e6ddc2ba1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,18 @@
+The following fonts are available for free, to use as you please.
+The minimal license is included in the header of each font.
+
+Copyright (c) 1999, Thomas A. Fine
+
+License to copy, modify, and distribute for both commercial and
+non-commercial use is herby granted, provided this notice
+is preserved.
+
+Email to my last name at head.cfa.harvard.edu
+http://hea-www.harvard.edu/~fine/
+
+Produced with bdfedit, a tcl/tk font editing program
+written by Thomas A. Fine
+
+The atari-small.sfd is a fontforge native font created by me.
+Copyright (C) 2007 Gurkan Sengun
+Released under the same license as the original font.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2f289d2f195
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Marco Pompili <marcs.pompili@gmail.com>
+# Maintainer: TDY <tdy@gmx.com>
+
+pkgname=ttf-atarismall
+pkgver=2.1
+pkgrel=1
+pkgdesc="A very small 4x8 font, originally desinged for the Atari 800 terminal emulator"
+arch=('any')
+url="http://gnu.ethz.ch/linuks.mine.nu/atari/"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=(http://gnu.ethz.ch/linuks.mine.nu/atari/AtariSmall.ttf
+ LICENSE)
+md5sums=('c6438c0c44cd78dd94d81fe19501981d'
+ 'd2d5d458e30a7143ec17383fee8f3b44')
+
+package() {
+ cd "$srcdir"
+ install -Dm644 AtariSmall.ttf "$pkgdir/usr/share/fonts/TTF/AtariSmall.ttf"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..33b7d65490db
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}