summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f010d73e32d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-cavafy-script
+ pkgdesc = Typeface based on the calligraphic style of the alexandrian poet C. P. Cavafy
+ pkgver = 1.1
+ pkgrel = 0
+ url = https://www.onassis.org/initiatives/cavafy-archive/cavafy-script
+ arch = any
+ license = custom:cc-by-nc-nd-4.0
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = ttf-font
+ source = https://github.com/onassis-org/cavafy-script/archive/v1.1.zip
+ source = https://creativecommons.org/licenses/by-nc-nd/4.0/legalcode.txt
+ md5sums = 3769277f4d1c2cab7749496d6cb8adff
+ md5sums = c70f85fe39eb601f25b595299c688bfd
+
+pkgname = ttf-cavafy-script
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b5ef32e2872
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sotiris Lamprinidis <sot.lampr at gmail dot com>
+
+pkgname=ttf-cavafy-script
+pkgver=1.1
+pkgrel=0
+pkgdesc="Typeface based on the calligraphic style of the alexandrian poet C. P. Cavafy"
+arch=('any')
+url="https://www.onassis.org/initiatives/cavafy-archive/cavafy-script"
+license=('custom:cc-by-nc-nd-4.0')
+depends=('fontconfig' 'xorg-font-utils')
+provides=('ttf-font')
+source=('https://github.com/onassis-org/cavafy-script/archive/v1.1.zip'
+ 'https://creativecommons.org/licenses/by-nc-nd/4.0/legalcode.txt')
+md5sums=('3769277f4d1c2cab7749496d6cb8adff'
+ 'c70f85fe39eb601f25b595299c688bfd')
+
+package() {
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+
+ install -m644 "$srcdir/cavafy-script-1.1/OpenType-TT/CavafyScriptTT.ttf" \
+ "$pkgdir/usr/share/fonts/TTF/CavafyScriptTT.ttf"
+
+ install -Dm644 legalcode.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+post_install () {
+ fontconfig
+}