summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d0f49077108..eac338c6fb5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = ttf-chunk
- pkgdesc = An ultra-bold slab serif typeface that is reminiscent of old American Western woodcuts, broadsides, and newspaper headlines. Used mainly for display, the fat block lettering is unreserved yet refined for contemporary use.
+ pkgdesc = An ultra-bold, ultra-awesome slab serif typeface
pkgver = 20180627
- pkgrel = 1
+ pkgrel = 2
url = http://theleagueofmoveabletype.com/chunk
arch = any
groups = lmt-fonts
- license = custom:OFL
- depends = fontconfig
- depends = xorg-fonts-encodings
- depends = xorg-font-utils
+ license = OFL
source = ttf-chunk-20180627.zip::https://github.com/theleagueof/chunk/archive/master.zip
sha256sums = f38062c4b6ecf42e0cc0b4ec3c8d6976c040ac2e87777f44cec6b1047470d949
diff --git a/PKGBUILD b/PKGBUILD
index c150837a03bf..28eb59545ab2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
# Maintainer: LightDot <lightdot -a-t- g m a i l>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: samæ <samæ at marvid dot fr>
_fnt_name=chunk
pkgname=ttf-$_fnt_name
pkgver=20180627
-pkgrel=1
-pkgdesc="An ultra-bold slab serif typeface that is reminiscent of old American Western woodcuts, broadsides, and newspaper headlines. Used mainly for display, the fat block lettering is unreserved yet refined for contemporary use."
+pkgrel=2
+pkgdesc="An ultra-bold, ultra-awesome slab serif typeface"
arch=('any')
url="http://theleagueofmoveabletype.com/$_fnt_name"
-license=('custom:OFL')
+license=('OFL')
groups=('lmt-fonts')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/master.zip")
sha256sums=('f38062c4b6ecf42e0cc0b4ec3c8d6976c040ac2e87777f44cec6b1047470d949')
package() {
- install -d "$pkgdir"/usr/share/fonts/OTF
- install -d "$pkgdir"/usr/share/fonts/TTF
- install -Dm644 "$srcdir/$_fnt_name"-master/*.otf "$pkgdir"/usr/share/fonts/OTF/
- install -Dm644 "$srcdir/$_fnt_name"-master/*.ttf "$pkgdir"/usr/share/fonts/TTF/
-
- install -Dm644 "$srcdir/$_fnt_name"-master/Open\ Font\ License.markdown "$pkgdir/usr/share/licenses/$pkgname"/OFL.txt
+ cd "$_fnt_name-master"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License.markdown
}