summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--font.install13
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..220aa18da415
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-code2000
+ pkgdesc = Unicode TT font with extensive glyph coverage
+ pkgver = 1.171
+ pkgrel = 3
+ url = http://www.code2000.net
+ install = font.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ source = ftp://ftp.tw.freebsd.org/pub/ports/distfiles/code2000-1.171/CODE2000.ZIP
+ md5sums = 1fa4e4b61d7ac0980b038e9260667a77
+
+pkgname = ttf-code2000
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9356f60d9886
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributor: Alex Suykov <axs@ukr.net>
+
+pkgname=ttf-code2000
+pkgver=1.171
+pkgrel=3
+pkgdesc="Unicode TT font with extensive glyph coverage"
+arch=('i686' 'x86_64')
+url="http://www.code2000.net"
+license=('custom')
+depends=('fontconfig' 'xorg-fonts-encodings')
+install=font.install
+source=(ftp://ftp.tw.freebsd.org/pub/ports/distfiles/code2000-1.171/CODE2000.ZIP)
+md5sums=('1fa4e4b61d7ac0980b038e9260667a77')
+
+package() {
+ install -D -m644 CODE2000.TTF "$pkgdir/usr/share/fonts/TTF/Code2000.ttf"
+ install -D -m644 CODE2000.HTM "$pkgdir/usr/share/licenses/ttf-code2000/Code2000.html"
+}
diff --git a/font.install b/font.install
new file mode 100644
index 000000000000..18666d2a3d6c
--- /dev/null
+++ b/font.install
@@ -0,0 +1,13 @@
+post_install() {
+ fc-cache -fs
+ mkfontscale usr/share/fonts/TTF
+ mkfontdir usr/share/fonts/TTF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}