summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
-rw-r--r--ttf.install20
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3dc581b171b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.0
+# Sat Jan 10 00:07:29 UTC 2015
+pkgbase = ttf-essays
+ pkgdesc = A font based on the typeface used in a 1743 English translation of Montaigne's Essays.
+ pkgver = 2.001
+ pkgrel = 2
+ url = http://www.thibault.org/fonts/essays/
+ install = ttf.install
+ arch = any
+ license = LGPL
+ depends = xorg-fonts-encodings
+ depends = xorg-fonts-alias
+ depends = xorg-font-utils
+ depends = fontconfig
+ source = http://www.thibault.org/fonts/essays/essays1743-2.001-1-ttf.tar.gz
+ sha256sums = 83a293f52dc0767adc5c57c619d99db0a5e1ba6fcdfa240ca719aa5643f10c5d
+
+pkgname = ttf-essays
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f66396a7b3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: procrastinator
+
+pkgname=ttf-essays
+pkgver=2.001
+pkgrel=2
+pkgdesc="A font based on the typeface used in a 1743 English translation of Montaigne's Essays."
+arch=('any')
+license=('LGPL')
+url="http://www.thibault.org/fonts/essays/"
+install=ttf.install
+depends=(xorg-fonts-encodings xorg-fonts-alias xorg-font-utils fontconfig)
+source=("http://www.thibault.org/fonts/essays/essays1743-$pkgver-1-ttf.tar.gz")
+sha256sums=('83a293f52dc0767adc5c57c619d99db0a5e1ba6fcdfa240ca719aa5643f10c5d')
+
+build() {
+ /bin/true
+}
+
+package() {
+ cd "$srcdir/essays1743"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..af1a4f80c636
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*