summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--ttf.install15
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46d0ea48ecf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-eurof
+ pkgdesc = The original eurofurence font designed for headlines, signs, badges, inscriptions, et al.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.eurofurence.net/eurofurence.html
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.eurofurence.net/eurof_tt.zip
+ md5sums = 19a13896e288a82a3e4eba1df21918f3
+
+pkgname = ttf-eurof
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..442cd4707148
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: TDY <tdy@gmx.com>
+
+pkgname=ttf-eurof
+pkgver=1.0
+pkgrel=1
+pkgdesc="The original eurofurence font designed for headlines, signs, badges, inscriptions, et al."
+arch=('any')
+url="http://www.eurofurence.net/eurofurence.html"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=(http://www.eurofurence.net/eurof_tt.zip)
+md5sums=('19a13896e288a82a3e4eba1df21918f3')
+
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 eurof*.ttf "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 eurof_tt.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..33b7d65490db
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}