summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--updatefont.install15
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..467400a08e0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-domine
+ pkgdesc = Domine is a perfect choice for newspapers or blogs where text is the main focus, from Pablo Impallari
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.impallari.com/projects/overview/domine/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/uploads/prosources/update-85-source.zip
+ md5sums = d1a26da138ff1fe248a213e1fee651aa
+
+pkgname = ttf-impallari-domine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9b0850ec0e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Marcos Heredia <chelqo@gmail.com>
+
+_font="domine"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=1
+pkgrel=1
+pkgdesc="Domine is a perfect choice for newspapers or blogs where text is the main focus, from Pablo Impallari"
+arch=(any)
+#url="http://www.impallari.com/${_font}/"
+url="http://www.impallari.com/projects/overview/${_font}/"
+screenshot="http://www.impallari.com/media/uploads/profotos/110-foto01-original.jpg"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+#source=("http://www.impallari.com/media/releases/${_font}-v${pkgver}.zip")
+source=("http://www.impallari.com/media/uploads/prosources/update-85-source.zip")
+md5sums=('d1a26da138ff1fe248a213e1fee651aa')
+
+package() {
+ cd ${srcdir}/D*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..43e14fbd0cff
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}