summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--updatefont.install16
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b20c77f4b912
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-dosis
+ pkgdesc = Very simple, rounded, sans serif font family, from Pablo Impallari
+ pkgver = 1.7
+ pkgrel = 1
+ url = http://www.impallari.com/dosis/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/releases/dosis-v1.7.zip
+ md5sums = 953fc04aaeccf773cdce445b96830f1d
+
+pkgname = ttf-impallari-dosis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d701e652af81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+_font="dosis"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=1.7
+pkgrel=1
+pkgdesc="Very simple, rounded, sans serif font family, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/${_font}/"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+source=("http://www.impallari.com/media/releases/${_font}-v${pkgver}.zip")
+md5sums=('953fc04aaeccf773cdce445b96830f1d')
+
+package() {
+ cd ${srcdir}/*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..7c7762f6887c
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}