summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d34d9ed863ea..758dcf3e4b2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = ttf-iosevka-ss02
- pkgdesc = A slender monospace typeface. Shape: Anonymous Pro
- pkgver = 2.2.1
- pkgrel = 2
- url = https://be5invis.github.io/Iosevka/
+ pkgdesc = Typeface family designed for coding, terminal use and technical documents.
+ pkgver = 29.0.4
+ pkgrel = 1
+ url = https://typeof.net/Iosevka/
arch = any
- license = custom:OFL
- depends = fontconfig
- depends = xorg-font-utils
- source = https://github.com/be5invis/Iosevka/releases/download/v2.2.1/iosevka-ss02-2.2.1.zip
- source = ttf-iosevka-ss02-2.2.1-2-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/master/LICENSE.md
- sha256sums = e2c7a197a6ff93e14fc98fcbdd7f437fefeaa9852d44930b8602e7bcfce2de24
- sha256sums = ecfd74a1d6749bf509cee122870da0186bccfae446e3f6bc5faff253577ab000
+ license = OFL
+ source = https://github.com/be5invis/Iosevka/releases/download/v29.0.4/PkgTTF-IosevkaSS02-29.0.4.zip
+ source = ttf-iosevka-ss02-29.0.4-1-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/v29.0.4/LICENSE.md
+ sha256sums = 74ca1fec5a2a7faab240acc41c9f59849377968812c5f7a175fdc6dc4958348a
+ sha256sums = 8c914a5c7d8d5e5be1ae07fd8591b437ece15b665f6ccc913cea050ffa8448f7
pkgname = ttf-iosevka-ss02
-
diff --git a/PKGBUILD b/PKGBUILD
index 52dbb5b61eb4..069281c8b515 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Markus Weimar <mail@markusweimar.de>
pkgname=ttf-iosevka-ss02
-pkgver=2.2.1
-pkgrel=2
-pkgdesc='A slender monospace typeface. Shape: Anonymous Pro'
+pkgver=29.0.4
+pkgrel=1
+pkgdesc='Typeface family designed for coding, terminal use and technical documents.'
arch=('any')
-url='https://be5invis.github.io/Iosevka/'
-license=('custom:OFL')
-depends=('fontconfig' 'xorg-font-utils')
-source=("https://github.com/be5invis/Iosevka/releases/download/v${pkgver}/iosevka-ss02-${pkgver}.zip"
- "${pkgname}-${pkgver}-${pkgrel}-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/master/LICENSE.md")
-sha256sums=('e2c7a197a6ff93e14fc98fcbdd7f437fefeaa9852d44930b8602e7bcfce2de24'
- 'ecfd74a1d6749bf509cee122870da0186bccfae446e3f6bc5faff253577ab000')
+url='https://typeof.net/Iosevka/'
+license=('OFL')
+source=("https://github.com/be5invis/Iosevka/releases/download/v${pkgver}/PkgTTF-IosevkaSS02-${pkgver}.zip"
+ "${pkgname}-${pkgver}-${pkgrel}-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/v${pkgver}/LICENSE.md")
+sha256sums=('74ca1fec5a2a7faab240acc41c9f59849377968812c5f7a175fdc6dc4958348a'
+ '8c914a5c7d8d5e5be1ae07fd8591b437ece15b665f6ccc913cea050ffa8448f7')
package() {
- install -d ${pkgdir}/usr/share/fonts/${pkgname}/
- install -m644 ${srcdir}/ttf/*.ttf ${pkgdir}/usr/share/fonts/${pkgname}/
+ install -d ${pkgdir}/usr/share/fonts/TTF/
+ install -m644 *.ttf ${pkgdir}/usr/share/fonts/TTF/
install -D -m644 ${pkgname}-${pkgver}-${pkgrel}-LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md
}