summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7149c83e598f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-iosevka-term-curly
+ pkgdesc = Typeface family designed for coding, terminal use and technical documents.
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://typeof.net/Iosevka/
+ arch = any
+ license = OFL
+ source = https://github.com/be5invis/Iosevka/releases/download/v3.0.0/ttf-iosevka-term-curly-3.0.0.zip
+ source = ttf-iosevka-term-curly-3.0.0-1-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/v3.0.0/LICENSE.md
+ sha256sums = 3b84ca6a1bfe3f646fd4e14b70c36e2b69bc5e09a2161eb252d5a1cbf719a4de
+ sha256sums = e61c0988bb231a321f14cce1b119a468f279ea86826c32e943ab16dbf08c1ba9
+
+pkgname = ttf-iosevka-term-curly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1863da0eebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Markus Weimar <mail@markusweimar.de>
+pkgname=ttf-iosevka-term-curly
+pkgver=3.0.0
+pkgrel=1
+pkgdesc='Typeface family designed for coding, terminal use and technical documents.'
+arch=('any')
+url='https://typeof.net/Iosevka/'
+license=('OFL')
+source=("https://github.com/be5invis/Iosevka/releases/download/v${pkgver}/ttf-iosevka-term-curly-${pkgver}.zip"
+ "${pkgname}-${pkgver}-${pkgrel}-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/v${pkgver}/LICENSE.md")
+sha256sums=('3b84ca6a1bfe3f646fd4e14b70c36e2b69bc5e09a2161eb252d5a1cbf719a4de'
+ 'e61c0988bb231a321f14cce1b119a468f279ea86826c32e943ab16dbf08c1ba9')
+
+package() {
+ install -d ${pkgdir}/usr/share/fonts/${pkgname}
+ install -m644 ${srcdir}/ttf/*.ttf ${pkgdir}/usr/share/fonts/${pkgname}
+ install -D -m644 ${pkgname}-${pkgver}-${pkgrel}-LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md
+}