summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
-rw-r--r--ttf-jenna-sue.install15
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ac981e0b531
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-jenna-sue
+ pkgdesc = The free TTF desktop version of the Jenna Sue font
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.dafont.com/jenna-sue.font
+ install = ttf-jenna-sue.install
+ arch = any
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://dl.dafont.com/dl/?f=jenna_sue
+ md5sums = 95e36cde53d7b94ee2435ce62a7f49e1
+
+pkgname = ttf-jenna-sue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23e1b7fd57e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Stephen Smith <stephen304@gmail.com>
+pkgname=ttf-jenna-sue
+pkgver=1.0
+pkgrel=1
+pkgdesc="The free TTF desktop version of the Jenna Sue font"
+arch=(any)
+url="http://www.dafont.com/jenna-sue.font"
+depends=(fontconfig xorg-font-utils)
+source=("http://dl.dafont.com/dl/?f=jenna_sue")
+md5sums=("95e36cde53d7b94ee2435ce62a7f49e1")
+install=$pkgname.install
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 "$srcdir/"*.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
diff --git a/ttf-jenna-sue.install b/ttf-jenna-sue.install
new file mode 100644
index 000000000000..c2f11b1d7317
--- /dev/null
+++ b/ttf-jenna-sue.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}