summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD20
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6d05569bde3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-kopubworld
+ pkgdesc = KoPub TrueType multilingual fonts.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.kopus.org/Biz/electronic/Font.aspx
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.kopus.org/Download_font.aspx?font_id=13&name=KOPUBWORLD_TTF_FONTS.zip
+ source = LICENSE::http://www.kopus.org/Download/%EC%84%9C%EC%B2%B4_%EB%9D%BC%EC%9D%B4%EC%84%A0%EC%8A%A4.pdf
+ md5sums = 2d87bb82ef1e3c3fa87f53eb1b69bd32
+ md5sums = d854e69fc19a8254e6677178a3018185
+
+pkgname = ttf-kopubworld
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8d39d933a9e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: JunYoung Gwak <i@jgwak.com>
+
+pkgname=ttf-kopubworld
+pkgver=1.0
+pkgrel=1
+pkgdesc="KoPub TrueType multilingual fonts."
+arch=('any')
+license=('custom')
+url="http://www.kopus.org/Biz/electronic/Font.aspx"
+depends=('fontconfig' 'xorg-font-utils')
+source=('http://www.kopus.org/Download_font.aspx?font_id=13&name=KOPUBWORLD_TTF_FONTS.zip'
+ 'LICENSE::http://www.kopus.org/Download/%EC%84%9C%EC%B2%B4_%EB%9D%BC%EC%9D%B4%EC%84%A0%EC%8A%A4.pdf')
+md5sums=('2d87bb82ef1e3c3fa87f53eb1b69bd32'
+ 'd854e69fc19a8254e6677178a3018185')
+
+package() {
+ install -dm 755 $pkgdir/usr/share/fonts/TTF
+ install -m 644 $srcdir/*.ttf $pkgdir/usr/share/fonts/TTF
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE.pdf
+}