summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD13
-rw-r--r--fontbuilder-python3.patch16
4 files changed, 8 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e52b02179756..c82479fe043a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ttf-monoid-git
pkgdesc = Open Source coding font
- pkgver = r427.a331c7c5
+ pkgver = r439.0673c8d6
pkgrel = 1
url = http://larsenwork.github.io/monoid/
arch = any
@@ -15,9 +15,7 @@ pkgbase = ttf-monoid-git
conflicts = ttf-mono16-git
conflicts = ttf-monoid
source = ttf-monoid-git::git://github.com/larsenwork/monoid.git
- source = fontbuilder-python3.patch
sha512sums = SKIP
- sha512sums = 7f06b8827ed12b3070512ae58424b92a05635eefe0dee0d6314f1b92230f431e2fde5a2d70adbff324bbcb4ce70b135ccda2a6dfaaeb7b6e4219a447034f00c0
pkgname = ttf-monoid-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 162985fec33b..d6dfafdb5050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgname=ttf-monoid-git
pkgdesc='Open Source coding font'
-pkgver=r427.a331c7c5
+pkgver=r439.0673c8d6
pkgrel=1
arch=(any)
license=(custom:MIT)
@@ -9,21 +9,14 @@ url=http://larsenwork.github.io/monoid/
makedepends=(git fontforge python)
conflicts=(ttf-mono16 ttf-mono16-git ttf-monoid)
provides=("${conflicts[@]}")
-source=("${pkgname}::git://github.com/larsenwork/monoid.git"
- 'fontbuilder-python3.patch')
-sha512sums=('SKIP'
- '7f06b8827ed12b3070512ae58424b92a05635eefe0dee0d6314f1b92230f431e2fde5a2d70adbff324bbcb4ce70b135ccda2a6dfaaeb7b6e4219a447034f00c0')
+source=("${pkgname}::git://github.com/larsenwork/monoid.git")
+sha512sums=('SKIP')
pkgver () {
cd "${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare () {
- cd "${pkgname}/Scripts"
- patch -p1 < "${srcdir}/fontbuilder-python3.patch"
-}
-
build () {
cd "${pkgname}"
export PYTHONPATH="$(pwd)/Scripts"
diff --git a/fontbuilder-python3.patch b/fontbuilder-python3.patch
deleted file mode 100644
index 38ee86fc43d1..000000000000
--- a/fontbuilder-python3.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/fontbuilder.py b/fontbuilder.py
-index c8d8ea5..5442246 100755
---- a/fontbuilder.py
-+++ b/fontbuilder.py
-@@ -58,9 +58,9 @@ def permutations():
- bitmap_max = 1 << count
-
- # Iterate over all possible permutations
-- for i in xrange(bitmap_max):
-+ for i in range(bitmap_max):
- # Map the iteration's permutations using a bitmap
-- bitmap = [i >> n & 1 for n in xrange(count)]
-+ bitmap = [i >> n & 1 for n in range(count)]
- for opts in _expand_options(bitmap):
- yield(int(float(i)/bitmap_max*100), opts)
-