summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--install15
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3938f955a9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-nishiki-teki
+ pkgdesc = A Unicode-based font inspired by a free shell of Ukagaka called “Nishiki”.
+ pkgver = 2.80
+ pkgrel = 1
+ url = http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.htm
+ install = install
+ arch = any
+ license = unknown
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki_2_80.zip
+ sha256sums = 0f0eced466e80e7ddc95eca4faba0dcf0cbc2e99f9f974747ae7d3217cb58546
+
+pkgname = ttf-nishiki-teki
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2736b1c3ab1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=ttf-nishiki-teki
+pkgver=2.80
+pkgrel=1
+pkgdesc="A Unicode-based font inspired by a free shell of Ukagaka called “Nishiki”."
+arch=('any')
+url="http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.htm"
+license=("unknown")
+depends=('fontconfig' 'xorg-font-utils')
+install='install'
+source=("http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki_${pkgver//./_}.zip")
+sha256sums=('0f0eced466e80e7ddc95eca4faba0dcf0cbc2e99f9f974747ae7d3217cb58546')
+
+package() {
+ cd $srcdir/nishiki-teki_${pkgver//./_}
+
+ install -Dm644 nishiki-teki.ttf $pkgdir/usr/share/fonts/TTF/nishiki-teki.ttf
+
+ install -Dm644 nishiki-teki.htm $pkgdir/usr/share/doc/$pkgname/nishiki-teki.htm
+ install -Dm644 img/banner_nishiki-teki.png $pkgdir/usr/share/doc/$pkgname/img/banner_nishiki-teki.png
+ install -Dm644 img/nishiki.css $pkgdir/usr/share/doc/$pkgname/img/nishiki.css
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..499f2221a38f
--- /dev/null
+++ b/install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}