summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
-rw-r--r--ttf-noto.install15
4 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf81d13e1a09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-noto
+ pkgdesc = Fonts support all languages/characters in Unicode
+ pkgver = 20150612
+ pkgrel = 1
+ url = http://www.google.com/get/noto
+ install = ttf-noto.install
+ arch = any
+ license = apache
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ provides = ttf-font
+ source = http://storage.googleapis.com/noto-website/pkgs/Noto-hinted.zip
+ md5sums = 077a9978839e37b29af710819fb17729
+
+pkgname = ttf-noto
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..328f83935969
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!ttf-noto.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ddc0e2fb1fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: tailinchu <use_my_id at gmail dot com>
+
+pkgname=ttf-noto
+pkgver=20150612
+pkgrel=1
+pkgdesc="Fonts support all languages/characters in Unicode"
+arch=('any')
+url="http://www.google.com/get/noto"
+license=('apache')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+makedepends=()
+conflicts=()
+provides=('ttf-font')
+source=("http://storage.googleapis.com/noto-website/pkgs/Noto-hinted.zip")
+install=$pkgname.install
+PKGEXT='.pkg.tar' # because XZ compression is awfully slow
+md5sums=('077a9978839e37b29af710819fb17729')
+
+package() {
+ mkdir -p $pkgdir/usr/share/fonts/{TTF,OTF}
+ cp $srcdir/*.ttf $pkgdir/usr/share/fonts/TTF
+ cp $srcdir/*.otf $pkgdir/usr/share/fonts/OTF
+ chmod 644 $pkgdir/usr/share/fonts/{TTF,OTF}/*
+}
diff --git a/ttf-noto.install b/ttf-noto.install
new file mode 100644
index 000000000000..f0d8d1e3773f
--- /dev/null
+++ b/ttf-noto.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/{TTF,OTF}
+ mkfontdir /usr/share/fonts/{TTF,OTF}
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}