summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
-rw-r--r--ttf-oxygen.install15
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d78bd753a321
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ttf-oxygen-git
+ pkgdesc = A desktop/gui font family for integrated use with the KDE desktop. (GIT version)
+ pkgver = 5.3.90.r168.4a2d1f7
+ pkgrel = 1
+ url = https://projects.kde.org/projects/playground/artwork/oxygen-fonts
+ install = ttf-oxygen.install
+ arch = any
+ license = custom:OFL
+ makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = fontforge
+ provides = ttf-oxygen
+ conflicts = ttf-oxygen
+ source = git://anongit.kde.org/oxygen-fonts.git
+ sha1sums = SKIP
+
+pkgname = ttf-oxygen-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..357c6a5a7794
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!ttf-oxygen.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0560eacb36d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Jerome Leclanche <jerome.leclanche+arch@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=ttf-oxygen-git
+pkgver=5.3.90.r168.4a2d1f7
+pkgrel=1
+pkgdesc="A desktop/gui font family for integrated use with the KDE desktop. (GIT version)"
+arch=("any")
+license=("custom:OFL")
+url="https://projects.kde.org/projects/playground/artwork/oxygen-fonts"
+makedepends=('git' 'cmake' 'extra-cmake-modules' 'fontforge')
+provides=("ttf-oxygen")
+conflicts=("ttf-oxygen")
+source=("git://anongit.kde.org/oxygen-fonts.git")
+sha1sums=("SKIP")
+install="ttf-oxygen.install"
+
+pkgver() {
+ cd oxygen-fonts
+ _ver="$(cat CMakeLists.txt | grep PROJECT_VERSION | head -n1 | cut -d '"' -f2)"
+ echo "$(echo ${_ver} | tr ' ' .).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../oxygen-fonts \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/ttf-oxygen.install b/ttf-oxygen.install
new file mode 100644
index 000000000000..f5837f7f6e30
--- /dev/null
+++ b/ttf-oxygen.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}