summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rwxr-xr-xLICENSE53
-rw-r--r--PKGBUILD43
-rw-r--r--ttf-pragmatapro.install15
5 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73d2c8bc0c7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-pragmatapro
+ pkgdesc = PragmataPro by Fabrizio Schiavi
+ pkgver = 0.821
+ pkgrel = 1
+ url = http://www.fsd.it/shop/fonts/pragmatapro/
+ install = ttf-pragmatapro.install
+ arch = any
+ license = http://www.fsd.it/fonts/eula.htm
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = LICENSE
+ md5sums = eb2608fd50ca421ecb9fc07de833a5ab
+
+pkgname = ttf-pragmatapro
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8eba6c8dd4dc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+src/
diff --git a/LICENSE b/LICENSE
new file mode 100755
index 000000000000..4f369395eec3
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,53 @@
+Font Designer and Hinting: Fabrizio Schiavi
+http://www.fsd.it/
+
+
+Copyright Property of Fabrizio Schiavi:
+http://www.fsd.it/
+
+
+Download the catalogue from my web site:
+http://www.fsd.it/fonts/fsd_font_catalog.pdf
+Keep in touch
+Fabrizio
+
+
+
+
+
+__________________________________
+
+FSD License agreement:
+version 1.6 (2014-05-08)
+
+(1) Purchasing a font you agree to the terms and conditions set herein.
+(2) Usage of this Software is limited to the number of users that you have stated during the purchased.
+Service bureau output does not count toward the amount of computers as long as the font being output is completely removed from the service bureau system after your job has been output.
+(3) You may copy the software, but only for backup purposes.
+(4) You may not rent, lease, loan, resell for profit, distribute, or network the Software.
+(5) You may use it as a font embedding for web pages (@ font-face) provided it is converted in a way that makes it impossible to recover the original font.
+(6) In no event will Fabrizio Schiavi be liable for any damages, including loss of data, or other incidental or consequential damages arising out of the use or inability to use the data supplied herein.
+(7) The Software and the accompanying articles are protected by the Copyright Law and international treaty. Unauthorized reproduction or distribution is subject to civil and criminal penalties.
+
+
+FSD Licenza dĠuso:
+
+(1) Con lĠacquisto del font si intendono accettate le condizioni elencate di seguito.
+(2) LĠutilizzo di questo Software  limitato al numero di utenti che hai dichiarato durante lĠacquisto.
+I service non rientrano nel numero di computer a condizione che subito dopo lĠuscita in pellicola del tuo lavoro venga rimosso dal computer.
+(3) Non puoi copiare il Software a nessun altro, solo fare backup per tuo uso.
+(4) Non puoi noleggiarlo, rivenderlo o distribuirlo.
+(5) Puoi usarlo come font embedding per pagine web (@font-face e simili) a condizione che venga convertito in modo tale da rendere impossibile il recupero del font originale.
+(6) In nessun caso Fabrizio Schiavi sarˆ risponsabile di eventuali perdite di dati o altri incidenti che possono essere causati dallĠistallazione e dallĠuso del Software.
+(7) Il Software  protetto dalle leggi internazionali del Diritto dĠAutore. Riproduzioni e distribuzioni non consentite sono azioni soggette a sanzioni civili e penali.
+
+
+
+
+__________________________________
+UPDATED END USER LICENSE AGREEMENT
+http://www.fsd.it/fonts/eula.htm
+UPDATED END USER LICENSE AGREEMENT
+http://www.fsd.it/fonts/eula.htm
+
+__________________________________ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9c6d1999d11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Bao Trinh <aur@qubidt.com>
+
+# requires that you already have a full copy of this font
+
+pkgname=ttf-pragmatapro
+pkgver=0.821
+pkgrel=1
+pkgdesc="PragmataPro by Fabrizio Schiavi"
+arch=('any')
+url="http://www.fsd.it/shop/fonts/pragmatapro/"
+license=('http://www.fsd.it/fonts/eula.htm')
+depends=('fontconfig' 'xorg-font-utils')
+install=$pkgname.install
+source=("LICENSE")
+md5sums=('eb2608fd50ca421ecb9fc07de833a5ab')
+
+package() {
+ msg "You need a full copy of this font in order to install it"
+ files=(
+ "PragmataProB_0821.ttf"
+ "PragmataProI_0821.ttf"
+ "PragmataProR_0821.ttf"
+ "PragmataProZ_0821.ttf"
+ "PragmataPro_Mono_B_0821.ttf"
+ "PragmataPro_Mono_I_0821.ttf"
+ "PragmataPro_Mono_R_0821.ttf"
+ "PragmataPro_Mono_Z_0821.ttf"
+ )
+ for i in "${files[@]}"
+ do
+ if [[ ! -f $i ]]; then
+ error "${i} not found"
+ return 1
+ else
+ msg "Found ${i}"
+ fi
+ done
+ msg "Found all files, instaling..."
+
+ install -d "$pkgdir/usr/share/fonts/TTF/"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname"
+}
diff --git a/ttf-pragmatapro.install b/ttf-pragmatapro.install
new file mode 100644
index 000000000000..388d6f24a1c3
--- /dev/null
+++ b/ttf-pragmatapro.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}